Bug 224086 - Not all licenses of plugin's components listed in plugin installation wizard
Not all licenses of plugin's components listed in plugin installation wizard
Status: VERIFIED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
7.3
All All
: P2 (vote)
: 7.3
Assigned To: pgebauer
nbre
: 73_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 13:29 UTC by Antonin Nebuzelsky
Modified: 2013-01-25 11:39 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2012-12-20 13:29:29 UTC
* 7.3 daily build
* select JIRA plugin in Plugins manager for installation
* only two licenses are listed in the installation wizard (modules JIRA [1.17.0] and WSDL4J [1.6.0])
Comment 1 Jiri Rechtacek 2012-12-20 17:15:04 UTC
Caused by missing the license attribute for all OSGi bundles in catalog.
NB7.3 Beta2 - http://dlc.sun.com.edgesuite.net/netbeans/7.3/beta2/uc2/catalog.xml
Dev UC - http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastSuccessfulBuild/artifact/nbbuild/nbms/updates.xml/*view*/

Needed to fix antsrc/MakeOSGi.java to generate the license for them.
Comment 2 Jiri Rechtacek 2013-01-07 13:59:08 UTC
Petr, are you fixing? Let me know if need any support from my side. Tx
Comment 3 pgebauer 2013-01-07 14:06:57 UTC
Firstly, I'm trying to figure out what license id should be used. It seems that some jars do not have any license inside (e.g.  javax-xml-soap.jar)
Comment 4 pgebauer 2013-01-08 13:29:04 UTC
It seems that the license attribute an its value is generated in MakeUpdateDesc.jave in the method fakeOSGiInfoXml(). I do not see any relation to MakeOSGi.java. It still not clear to me what license files should jar files use.
Comment 5 pgebauer 2013-01-17 23:03:07 UTC
I have added missing licenses and have edited catalog.xml. Please, check Jira installation from any RC1 build.
Comment 6 pgebauer 2013-01-23 10:34:52 UTC
The workaround exists.
Comment 7 Antonin Nebuzelsky 2013-01-23 12:40:23 UTC
(In reply to comment #6)
> The workaround exists.

The workaround will be applied to 7.3 thus changing keyword to 73_HR_FIX.
Comment 8 Tomas Danek 2013-01-25 11:16:41 UTC
I don't have a deep insight in this issue, but licence list seems to be reasonable in NetBeans IDE 7.3 RC1 (Build 201301240957): Can someone confirm that list is correct?

javax.servlet
org.apache.commons.discovery
javax.xml.soap
org.apache.axis
javax.xml.rpc
JIRA
Atlassian connector for Eclipse Jira Core
JavaMail API
Atlassian connector for Eclipse Commons Core
WSDL4J
Mylyn Commons Soap
Comment 9 Jiri Rechtacek 2013-01-25 11:23:37 UTC
(In reply to comment #8)
> I don't have a deep insight in this issue, but licence list seems to be
> reasonable in NetBeans IDE 7.3 RC1 (Build 201301240957): Can someone confirm
> that list is correct?
> 
> javax.servlet
> org.apache.commons.discovery
> javax.xml.soap
> org.apache.axis
> javax.xml.rpc
> JIRA
> Atlassian connector for Eclipse Jira Core
> JavaMail API
> Atlassian connector for Eclipse Commons Core
> WSDL4J
> Mylyn Commons Soap

That's correct: the jars are - c.atlassian.connector.eclipse.commons.core,\
c.atlassian.connector.eclipse.jira.core,\
jira,\
o.apache.axis,\
o.apache.commons.discovery,\        
o.eclipse.mylyn.monitor.ui.dummy,\
o.eclipse.mylyn.commons.soap,\
javax.servlet,\
javax.wsdl,\
javax.xml.rpc,\
javax.xml.soap,\
Comment 10 Tomas Danek 2013-01-25 11:39:20 UTC
thnx, marking as verified then.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo