Bug 223794 - Javadoc -locale tr is generating erroneous html
Javadoc -locale tr is generating erroneous html
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.2.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
http://bugs.sun.com/bugdatabase/view_...
jdk_bug_9005673
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 15:30 UTC by hrzafer
Modified: 2013-08-05 05:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (987.66 KB, text/plain)
2012-12-13 15:30 UTC, hrzafer
Details
javadoc source view (26.19 KB, image/png)
2013-08-05 05:13 UTC, hrzafer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hrzafer 2012-12-13 15:30:12 UTC
The source of index.html 

<html lang="tr">
<head>
<!-- Generated by javadoc on Thu Dec 13 17:20:07 EET 2012 -->
<meta http-equiv="Content-Type" content="text/html" charset="UTF-8">
<tıtle>Javanta</tıtle>
<scrıpt type="text/javascript">
    targetPage = "" + window.location.search;
    if (targetPage != "" && targetPage != "undefined")
        targetPage = targetPage.substring(1);
    if (targetPage.indexOf(":") != -1)
        targetPage = "undefined";
    function loadFrames() {
        if (targetPage != "" && targetPage != "undefined")
             top.classFrame.location = top.targetPage;
    }
</scrıpt>

As seen <html lang="tr"> and the keywords script and title are 'scıpt' and 'tıtle'. Instead of 'i' Turkish dotless i is used. My OS'es language is also Turkish.

Product Version = NetBeans IDE 7.2.1 (Build 201210100934)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_10
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Comment 1 hrzafer 2012-12-13 15:30:41 UTC
Created attachment 129338 [details]
IDE log
Comment 2 Ralph Ruijs 2012-12-19 13:23:45 UTC
The javadoc is generated using the javadoc tool. It happens in versions 1.7 and 1.8, but is working correctly in 1.6.
Comment 3 Stanislav Aubrecht 2013-08-01 14:43:03 UTC
Reporter, please provide some steps to reproduce, thanks.
Comment 4 hrzafer 2013-08-05 05:13:52 UTC
Created attachment 138262 [details]
javadoc source view
Comment 5 hrzafer 2013-08-05 05:18:37 UTC
After upgrading to Netbeans 7.2 (64-bit), I can't get properly generated javadocs. There is no css and there are non-ascii characters as in the image:

I believe it is something about the <html lang="tr"> line. Because the ı character in the keywords script and title is a Turkish character. And its capital version is I. I'm on Windows 7 Turkish by the way.

So steps to reproduce:

1- Set regional settings to Turkish. Or somehow make sure that the edfault locale for JVM or Netbeans is tr_TR
2- Use Netbeans 7
3- Try to generate javadoc.

In Turkish there are two similar but different letters. One's lower case and the other's upper case correspons to the I-i in English.

İ-i and I-ı


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo