Bug 223658 - Diff view should not respect breakpoints
Diff view should not respect breakpoints
Status: RESOLVED DUPLICATE of bug 128907
Product: utilities
Classification: Unclassified
Component: Diff
PC Windows 7 x64
: P4 (vote)
: 7.4
Assigned To: Ondrej Vrabec
Depends on:
  Show dependency treegraph
Reported: 2012-12-11 14:00 UTC by crazyjavahacking
Modified: 2016-05-23 18:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT

Diff view (72.07 KB, image/png)
2012-12-11 14:00 UTC, crazyjavahacking

Note You need to log in before you can comment on or make changes to this bug.
Description crazyjavahacking 2012-12-11 14:00:35 UTC
Created attachment 129205 [details]
Diff view

Diff view should not respect breakpoints, otherwise breakpoints look exactly same as removed lines.

See attachment and note that the first red line is a breakpoint and the last 2 lines were actually removed.

NetBeans Dev 20121127, JDK 6u37 32bit
Comment 1 Tomas Stupka 2013-01-09 10:22:55 UTC
agree, we should do something about it. if nothing else, it is distracting.

on the other hand, while the color is almost the same, obviously, the graphical visualization of a breakpoint and a removed block is distinct and quite distinguishable. minor UI problem -> p4

UI team on CC
Comment 2 Tomas Stupka 2013-01-09 10:26:20 UTC
actaully, there is no need for the UI guys, but maybe the debugger team could help out ...
Comment 3 markiewb 2016-05-23 18:59:44 UTC

*** This bug has been marked as a duplicate of bug 128907 ***

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo