Bug 223544 - Deadlock on attempt to show New Project Wizard
Deadlock on attempt to show New Project Wizard
Status: RESOLVED DUPLICATE of bug 214872
Product: projects
Classification: Unclassified
Component: Generic Projects UI
7.3
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Milos Kleint
issues@projects
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-09 09:45 UTC by Marian Petras
Modified: 2012-12-11 13:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
screenshot of the deadlocked IDE (202.42 KB, image/png)
2012-12-09 09:48 UTC, Marian Petras
Details
overview of threads (JVisualVM screenshot) (98.44 KB, image/png)
2012-12-09 09:49 UTC, Marian Petras
Details
full thread-dump (generated by JVisualVM) (31.73 KB, text/plain)
2012-12-09 09:50 UTC, Marian Petras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2012-12-09 09:45:29 UTC
I had a couple (2-3) of small Java projects open and wanted to create a new Maven projects. So I went to the main menu and selected File > New Project... and the deadlock occurred.

At least the following threads are involved in the deadlock:

   Folders Instance Processor
   AWT-EventQueue-1
   AWT-Windows

See the attachments for more information.
Comment 1 Marian Petras 2012-12-09 09:48:21 UTC
Created attachment 129098 [details]
screenshot of the deadlocked IDE
Comment 2 Marian Petras 2012-12-09 09:49:43 UTC
Created attachment 129099 [details]
overview of threads (JVisualVM screenshot)
Comment 3 Marian Petras 2012-12-09 09:50:19 UTC
Created attachment 129100 [details]
full thread-dump (generated by JVisualVM)
Comment 4 Marian Petras 2012-12-09 09:52:10 UTC
System info:

   NetBeans 7.3 beta 2
   JDK 1.7.0_09 64bit
   Windows 7 64bit
Comment 5 Marian Petras 2012-12-09 10:06:31 UTC
The projects already open were:

    - Java project
    - Web project

Both projects are Ant-based and very small.
Comment 6 Marian Petras 2012-12-09 10:37:50 UTC
The Avast! antivirus software was running and broken at the time this deadlock occured - it might be that the Avast's issue influenced NetBeans execution.
Comment 7 Milos Kleint 2012-12-11 13:41:40 UTC
duplicate of issue 214872? apparently a jdk bug

*** This bug has been marked as a duplicate of bug 214872 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo