Bug 223505 - Java CodeCompletion took 4560 ms.
Java CodeCompletion took 4560 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Editor
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 21:53 UTC by mcdev1
Modified: 2012-12-11 09:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (112.97 KB, application/nps)
2012-12-07 21:53 UTC, mcdev1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mcdev1 2012-12-07 21:53:32 UTC
This bug was originally marked as duplicate of bug 200558, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Linux

User Comments:
mcdev1: Typed "throw new IllegalS" and pressed control-space.



Maximum slowness yet reported was 4560 ms, average is 4560
Comment 1 mcdev1 2012-12-07 21:53:35 UTC
Created attachment 129068 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2012-12-10 12:48:41 UTC
Mílo, please notice the presence of about ten
[Was:org.netbeans.editor.GlyphGutter/org.netbeans.editor.GlyphGutter$8]	
threads. That is unlikely what you guys want, right?
Comment 3 David Strupl 2012-12-11 09:27:41 UTC
Dusan, please check the snapshot. Thanks.
Comment 4 Dusan Balek 2012-12-11 09:46:40 UTC
Time spent in the 'analyze' phase of the javac compilation that seems to be
competing for an IO with a native executor. As 'Please wait' is displayed in code completion meanwhile, closing as wontfix.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo