Bug 223361 - Let user copy Stack Trace from Test output
Let user copy Stack Trace from Test output
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: JUnit
7.3
PC Windows XP
: P2 with 1 vote (vote)
: 7.4
Assigned To: Theofanis Oikonomou
junit-issues@java
: PLAN
: 195866 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 06:00 UTC by bht
Modified: 2013-02-16 01:53 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Simple testcase in zip file (2.09 KB, application/zip)
2012-12-06 06:00 UTC, bht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2012-12-06 06:00:13 UTC
Created attachment 128930 [details]
Simple testcase in zip file

I let NetBeans generate a simple Maven project and let it generate a test class for the generated main class.

In the main class I add an exception. When this exception is thrown during the JUnit test, then I can see the stack trace only in the test window not in the output window.

This stack trace cannot be copied to the clipboard. Hyperlinking is not supported in it.

It would be good if the stack trace could be made more useful.
Comment 1 Milos Kleint 2012-12-06 07:15:50 UTC
(In reply to comment #0)
> Created attachment 128930 [details]
> Simple testcase in zip file
> 
> I let NetBeans generate a simple Maven project and let it generate a test class
> for the generated main class.
> 
> In the main class I add an exception. When this exception is thrown during the
> JUnit test, then I can see the stack trace only in the test window not in the
> output window.

in output window, there is a hyperlink in the surefire plugin output, when clicked one is shown output of all failing tests along with stacktraces hyperlinked.

> 
> This stack trace cannot be copied to the clipboard. Hyperlinking is not
> supported in it.
> 
> It would be good if the stack trace could be made more useful.

the test output window is managed under different component, reassigning
Comment 2 bht 2012-12-06 08:21:34 UTC
Thanks very much. I did not notice the link. Now I don't need this myself anymore but perhaps it is still useful for others.
Comment 3 Theofanis Oikonomou 2013-01-10 13:07:44 UTC
*** Bug 195866 has been marked as a duplicate of this bug. ***
Comment 4 Theofanis Oikonomou 2013-02-14 15:18:24 UTC
Changeset: ba71fe90d9d4
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2013-02-14 16:16
Message:   
Issue #223361 - Let user copy Stack Trace from Test output
Comment 5 Quality Engineering 2013-02-16 01:53:22 UTC
Integrated into 'main-golden', will be available in build *201302152300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ba71fe90d9d4
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #223361 - Let user copy Stack Trace from Test output


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo