Bug 223339 - java.lang.OutOfMemoryError: GC overhead limit exceeded
java.lang.OutOfMemoryError: GC overhead limit exceeded
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Hints
7.3
PC Linux
: P2 (vote)
: 7.3
Assigned To: Jan Lahoda
issues@java
http://netbeans.org/projects/profiler...
: PERFORMANCE
: 224335 224422 224580 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-05 17:23 UTC by Jiri Kovalsky
Modified: 2013-01-07 17:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Hadanka.java file 100% reproducing the OOME. (7.67 KB, text/x-java)
2012-12-05 17:48 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2012-12-05 17:23:15 UTC
NetBeans IDE Dev (Build 201212050001) (#115c4cf91d73)
Linux version 3.0.0-12-generic running on amd64
1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04; Oracle Corporation
Java(TM) SE Runtime Environment 1.7.0_10-ea-b15
/home/cesilko/Java/jdk1.7.0_10/jre
cs_CZ (nb); UTF-8
/home/cesilko
/home/cesilko
/home/cesilko/.netbeans/dev
/home/cesilko/.cache/netbeans/dev
/home/cesilko/NetBeans/trunk/nb

Description:
============
I was working on a simple 1 class Java application. I ran it 3 times, debugged it once and then ran it again twice. Then I opened Favorites view and added a directory with 4 *.class files, 2 *.java files and 1 *.txt file. I opened Hadanka.java into Editor and scrolled down a bit. After a while the OOME occurred.

I can provide both the simple project and mentioned Java file if necessary.
Comment 1 Jiri Kovalsky 2012-12-05 17:30:33 UTC
Heap dump was provided off-line to Tomas Hurka.
Comment 2 Jiri Kovalsky 2012-12-05 17:48:26 UTC
Created attachment 128919 [details]
Hadanka.java file 100% reproducing the OOME.

Further investigation showed that it's enough just to open this Hadanka.java file and after few seconds the IDE becomes unresponsive.
Comment 3 Tomas Hurka 2012-12-05 22:10:44 UTC
Heap dump is available at <http://netbeans.org/projects/profiler/downloads/download/Heapdumps/heapdump-223339.zip>
Comment 4 Tomas Hurka 2012-12-06 08:58:59 UTC
Reassigning to java/hints. 90% of the heap is retained by org.netbeans.modules.java.hints.bugs.NPECheck$VisitorImpl#1 842,121,908 (90.7%)
Comment 5 Quality Engineering 2012-12-07 02:40:52 UTC
Integrated into 'main-golden', will be available in build *201212070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5279ebd4c213
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #223339: handling of many embedded loops without exponential explosion
Comment 6 Jan Lahoda 2012-12-07 08:02:53 UTC
Thanks for the testcase.
Comment 7 Jiri Kovalsky 2012-12-10 10:22:20 UTC
Product Version: NetBeans IDE Dev (Build 201212090001)
Java: 1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-ea-b15
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/dev
Cache directory: /home/cesilko/.cache/netbeans/dev

Verified. Thanks for the quick fix.
Comment 8 bornoz 2012-12-18 15:56:31 UTC
Hi,
I had the same issue and referenced here.
I already attached the file to the following issue.
http://netbeans.org/bugzilla/show_bug.cgi?id=223740

Thanks for your concern.
Comment 9 Jan Lahoda 2013-01-03 22:27:07 UTC
*** Bug 224422 has been marked as a duplicate of this bug. ***
Comment 10 Jan Lahoda 2013-01-03 22:29:24 UTC
*** Bug 224335 has been marked as a duplicate of this bug. ***
Comment 11 Jan Lahoda 2013-01-07 17:24:07 UTC
*** Bug 224580 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo