Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 223236 - AssertionError: Invalid wrapLine[0]: WL[0]: SV:NULL; x=0.0 [0,0] EV:<3112,3134> WL[1]: SV:<3134,3171>; x=296.0 [1,1] EV:<3171,3181> WL[2]: SV:<3181,3209>; x=224.0 [2,4] <3209,3220> EV:NUL
AssertionError: Invalid wrapLine[0]: WL[0]: SV:NULL; x=0.0 [0,0] EV:<311...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-04 10:14 UTC by Exceptions Reporter
Modified: 2012-12-05 02:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.48 KB, text/plain)
2012-12-04 10:14 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-12-04 10:14:23 UTC
This bug was originally marked as duplicate of bug 222191, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201212030001)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Linux

Stacktrace: 
java.lang.AssertionError: Invalid wrapLine[0]:

    WL[0]: SV:NULL; x=0.0 [0,0] EV:<3112,3134>
    WL[1]: SV:<3134,3171>; x=296.0 [1,1] EV:<3171,3181>
    WL[2]: SV:<3181,3209>; x=224.0 [2,4] <3209,3220> EV:NULL
   at org.netbeans.modules.editor.lib2.view.ParagraphViewChildren.modelToViewChecked(ParagraphViewChildren.java:491)
   at org.netbeans.modules.editor.lib2.view.ParagraphView.modelToViewChecked(ParagraphView.java:382)
   at org.netbeans.modules.editor.lib2.view.DocumentViewChildren.modelToViewChecked(DocumentViewChildren.java:321)
   at org.netbeans.modules.editor.lib2.view.DocumentView.modelToViewNeedsLock(DocumentView.java:730)
   at org.netbeans.modules.editor.lib2.view.DocumentView.modelToViewChecked(DocumentView.java:716)
   at org.netbeans.modules.editor.lib2.view.EditorView.modelToView(EditorView.java:249)
Comment 1 Exceptions Reporter 2012-12-04 10:14:24 UTC
Created attachment 128824 [details]
stacktrace
Comment 2 Miloslav Metelka 2012-12-04 12:47:02 UTC
http://hg.netbeans.org/jet-main/rev/63a4bfb0e2eb
Comment 3 Quality Engineering 2012-12-05 02:56:16 UTC
Integrated into 'main-golden', will be available in build *201212050001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/63a4bfb0e2eb
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #223236 - AssertionError: Invalid wrapLine[0]: WL[0]: SV:NULL; x=0.0 [0,0] EV:<3112,3134> WL[1]: SV:<3134,3171>; x=296.0 [1,1] EV:<3171,3181> WL[2]: SV:<3181,3209>; x=224.0 [2,4] <3209,3220> EV:NUL.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo