Bug 223142 - 15s in Mac OS X refreshing menu - AWTTask.waitFor
15s in Mac OS X refreshing menu - AWTTask.waitFor
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
7.3
Macintosh (x86) Mac OS X
: P2 (vote)
: 7.3.1
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT perf-profileme 73pa...
: PERFORMANCE
: 230273 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-02 16:45 UTC by sreimers
Modified: 2013-07-17 14:01 UTC (History)
42 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (173.71 KB, application/nps)
2012-12-02 16:45 UTC, sreimers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2012-12-02 16:45:07 UTC
This bug was originally marked as duplicate of bug 211284, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201211300001)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b09, Java(TM) SE Runtime Environment, 1.8.0-ea-b65
OS: Mac OS X
Maximum slowness yet reported was 15318 ms, average is 15318
Comment 1 sreimers 2012-12-02 16:45:11 UTC
Created attachment 128723 [details]
nps snapshot
Comment 2 Jan Becicka 2013-03-25 07:09:50 UTC
160 reports
Comment 3 Stanislav Aubrecht 2013-04-18 08:01:53 UTC
The fix for #211284 is actually doesn't fix anything, the proper one is in core-main d8bfecf76cd1
Comment 4 Quality Engineering 2013-04-19 03:23:37 UTC
Integrated into 'main-golden', will be available in build *201304182301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d8bfecf76cd1
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #223142 - don't initialize menu components when the Frame is (de)activated - proper fix
Comment 5 Tomas Danek 2013-05-03 11:46:56 UTC
Stando, please backport.
Comment 6 Stanislav Aubrecht 2013-05-06 09:46:46 UTC
backported to release73 branch as 155d55c4001d
Comment 7 Quality Engineering 2013-05-07 00:19:05 UTC
Integrated into 'releases', will be available in build *201305062200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/155d55c4001d
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #223142 - backport of d8bfecf76cd1
Comment 8 Jaroslav Havlin 2013-07-17 14:01:41 UTC
*** Bug 230273 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo