Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 223077 - SceneBuilder: Set classpath from Maven Dependencies
SceneBuilder: Set classpath from Maven Dependencies
Status: RESOLVED DUPLICATE of bug 222295
Product: javafx
Classification: Unclassified
Component: Visual Tool Integration
7.2
PC Linux
: P1 with 1 vote (vote)
: TBD
Assigned To: Petr Somol
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 18:01 UTC by puce
Modified: 2012-12-03 09:46 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description puce 2012-11-30 18:01:50 UTC
When opening an FXML file from a Maven project in SceneBuilder then the Maven Dependencies should be used to set the classpath in the SceneBuilder.

Currently I sometimes get NullPointerExceptions and sometimes error messages that there are classpath issues.

Currently the integration is not useable if custom controls are used -> P1

Sample FXML file:

<?xml version="1.0" encoding="UTF-8"?>

<?import java.lang.*?>
<?import javafx.scene.*?>
<?import javafx.scene.control.*?>
<?import javafx.scene.layout.*?>
<?import somepackage.*?>

<fx:root type="SomeControl" xmlns:fx="http://javafx.com/fxml">
    <Label text="%BottomTestPane.Label.text"/>
</fx:root>

Note that the runtime loads the FXML file correctly.
Comment 1 Petr Somol 2012-12-03 09:14:05 UTC

*** This bug has been marked as a duplicate of bug 222295 ***
Comment 2 Stepan Zebra 2012-12-03 09:46:07 UTC
(In reply to comment #0)
> When opening an FXML file from a Maven project in SceneBuilder then the Maven
> Dependencies should be used to set the classpath in the SceneBuilder.
> 
> Currently I sometimes get NullPointerExceptions and sometimes error messages
> that there are classpath issues.
> 

Maven JavaFX projects are not currently supported in NB, however once they are, this would be a useful functionally for custom FXML controls.
Petr, consider keeping this as a separate enhancement, as issue 222295 is more of a platform/activation problem.

> Currently the integration is not useable if custom controls are used -> P1
> 
> Sample FXML file:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> 
> <?import java.lang.*?>
> <?import javafx.scene.*?>
> <?import javafx.scene.control.*?>
> <?import javafx.scene.layout.*?>
> <?import somepackage.*?>
> 
> <fx:root type="SomeControl" xmlns:fx="http://javafx.com/fxml">
>     <Label text="%BottomTestPane.Label.text"/>
> </fx:root>
> 
> Note that the runtime loads the FXML file correctly.

SceneBuilder functionality is still limited in this way. See
http://docs.oracle.com/javafx/scenebuilder/1/release_notes_1-0/jsbpub-release_notes_1-0.htm
Some progress is being made for the upcoming SB 1.1 release. I suggest you to join the JIRA project, so you'll be able to see all the open issues and report newly discovered problems.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo