Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 223051 - AssertionError at org.netbeans.modules.web.webkit.debugging.TransportHelper.sendBlockingCommand
AssertionError at org.netbeans.modules.web.webkit.debugging.TransportHelper.s...
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Navigator
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Jan Becicka
Vladimir Riha
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 13:12 UTC by Petr Jiricka
Modified: 2012-12-03 08:31 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.21 KB, text/plain)
2012-11-30 13:12 UTC, Petr Jiricka
Details
stacktrace (6.65 KB, text/plain)
2012-11-30 13:35 UTC, Vladimir Riha
Details
stacktrace (6.53 KB, text/plain)
2012-11-30 14:17 UTC, Marek Fukala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-11-30 13:12:13 UTC
Build: NetBeans IDE Dev (Build web-main-9389-on-20121130)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-ea-b15
OS: Mac OS X

User Comments:
pjiricka: I believe it was:

1. Created the BackboneWineCellar sample HTML5 project
2. Close index.html
3. Run it in Chrome
4. Enable select mode and select "2009 Syrah Washington, USA"
5. In the popup menu of the selected node in navigator, select Go to Source




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.web.webkit.debugging.TransportHelper.sendBlockingCommand(TransportHelper.java:113)
   at org.netbeans.modules.web.webkit.debugging.api.Runtime.evaluate(Runtime.java:117)
   at org.netbeans.modules.web.inspect.webkit.WebKitPageModel.invokeInAllDocuments(WebKitPageModel.java:662)
   at org.netbeans.modules.web.inspect.webkit.WebKitPageModel$WebPaneSynchronizer.updateSelection(WebKitPageModel.java:887)
   at org.netbeans.modules.web.inspect.webkit.WebKitPageModel$WebPaneSynchronizer.updateSelection(WebKitPageModel.java:881)
   at org.netbeans.modules.web.inspect.webkit.WebKitPageModel$WebPaneSynchronizer.updateSelection(WebKitPageModel.java:877)
Comment 1 Petr Jiricka 2012-11-30 13:12:16 UTC
Created attachment 128647 [details]
stacktrace
Comment 2 Petr Jiricka 2012-11-30 13:19:31 UTC
Now happens to me after every keystroke in index.html => P2.
Comment 3 Vladimir Riha 2012-11-30 13:35:36 UTC
Created attachment 128651 [details]
stacktrace

To reproduce:
- run some html file in Chrome 
- start Inspect Mode (note that Navigator contains some dynamic elements)
- left click on ANY element in Navigator
Comment 4 Marek Fukala 2012-11-30 14:17:34 UTC
Created attachment 128656 [details]
stacktrace
Comment 5 Marek Fukala 2012-11-30 14:18:42 UTC
this IMO belongs to web.inspect as 

web.inspect.webkit.WebKitPageModel$WebPaneSynchronizer.updateSelection() calls the TransportHelper.sendBlockingCommand() in EDT.
Comment 6 Jan Stola 2012-11-30 14:44:08 UTC
This is a regression caused by
http://hg.netbeans.org/web-main/rev/e433cf9cd71b
Honzo B., what was the reason for this change? Could you, please, revert it, i.e., stop calling Page.setSelectedNodes() in event-dispatch thread.

I understand that you overlooked that because the assertion is thrown when the Select Mode is turned on in the browser only. I should probably add another assertion into setSelectedNodes() directly to catch this kind of problems immediately.
Comment 7 Jan Stola 2012-11-30 15:54:52 UTC
I have reverted the mentioned change. Honzo B., please, let me know if there was some strong reason for it. If so, then we will have to resolve it in a different way. Thank you in advance.

Modified file: http://hg.netbeans.org/web-main/rev/f5d91a212f18
Comment 8 Jan Becicka 2012-12-03 08:31:31 UTC
Thanks and sorry. There is some minor issue with selection, which needs to be resolved.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo