Bug 222981 - General editor options has a java oriented check box
General editor options has a java oriented check box
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Code folding
7.3
PC Solaris
: P3 (vote)
: 7.4
Assigned To: Svata Dedic
issues@editor
: PLAN
: 140762 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 14:24 UTC by Alexander Simon
Modified: 2013-04-12 09:31 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2012-11-29 14:24:26 UTC
Check box "Javadoc Comments" should be language neutral.
Comment 1 Svata Dedic 2012-11-29 14:56:20 UTC
If you refer to Tools | Options > Editor > Collapse by default: Javadoc Comments, then yes.
There are pending requests in CSL to support language specific code folding categories, which should be then propagated somehow to the UI/options. I would like to address those enhancements together.
Comment 2 Alexander Simon 2012-11-29 15:18:48 UTC
(In reply to comment #1)
> If you refer to Tools | Options > Editor > Collapse by default: Javadoc
> Comments, then yes.
Yes, IMHO "Javadoc Comments" can be replaced something language neutral.
For example: "Documentation comments".
Most of languages have own name of such comments.
For example C/C++ language has Doxygen Comments.
Comment 3 Svata Dedic 2012-11-30 09:44:16 UTC
*** Bug 140762 has been marked as a duplicate of this bug. ***
Comment 4 Svata Dedic 2013-04-12 09:31:38 UTC
Implemented as part of code folding changes, see issue #226413 and issues referenced form there.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo