Bug 222888 - Problem in connecting to the repository (Test spec TS_73_CVS)
Problem in connecting to the repository (Test spec TS_73_CVS)
Status: RESOLVED INVALID
Product: versioncontrol
Classification: Unclassified
Component: CVS
7.3
PC All
: P2 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 12:01 UTC by divya_pithwa
Modified: 2012-12-04 06:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Error while connecting to the repository (88.50 KB, image/png)
2012-11-28 12:01 UTC, divya_pithwa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description divya_pithwa 2012-11-28 12:01:58 UTC
Created attachment 128504 [details]
Error while connecting to the repository

In test spec http://wiki.netbeans.org/TS_73_CVS using NB 7.3 Beta on Windows XP, I am having problem after the 4th step of 1.1Test Suit: Setting up CVSRoot.
As mentioned in the test spec I did the following steps:
1. I installed the CVS plugin through Tools->Plugins menu.
2. I invoked the Team | CVS | Checkout... action from main menu.
3. A Checkout dialogue appeared in which I set the CVS Root field to ":pserver:anonymous@netcatcvstribe.cvs.sourceforge.net:/cvsroot/netcatcvstribe", as it was asked to give the CVS Root in the format :pserver:username@hostname:/repository_path.
4. After this I set the password as "tribecvs" and to verify functionality of proxy configuration I clicked the "proxy configuration" dialogue.
5. A "Options" dialogue appeared in which by default the Web Browser field contained "<Default System Browser>" and in Proxy Settings: the second option "Use System Proxy Settings" was selected. I clicked the OK button.
6. Then I pressed the Next button in the Checkout dialogue to see the expected result. The expected result should be as follows:
EXPECTED RESULT: Press Next button. Next dialog of

"Checkout"

should show up. Verify all {"Browse..."} buttons in second step of "Checkout" dialog. Push "Finish" button. Verify result of Checkout action.

But I am getting the following error:
Please check username, password and repository.

As per Marco's mail in the mailing list, it is working fine on Mac OS but he is also facing the same problem on Windows 7.
Comment 1 Michel Graciano 2012-11-28 13:03:39 UTC
I can reproduce it at Ubuntu using the information posted here, but i can connect to my CVS server normally. I tried it at 7.2 and it does not work as well.
Looks like the credentials are incorrect.
Comment 2 marco76 2012-11-28 13:21:07 UTC
Some extra information:

as Michel wrote the connection with the password 'tribecvs' doesn't work because the credentials are not good.

The issue is with the anonymous connection.

the project on sf.net has been created by the previous tribe to test CVS:
http://netbeans.org/projects/www/lists/netcat/archive/2012-05/message/25

here the details for the anonymous connection:
http://sourceforge.net/scm/?type=cvs&group_id=615255
(:pserver:anonymous@netcatcvstribe.cvs.sourceforge.net:/cvsroot/netcatcvstribe)

with NB 7.2 Win 7 I can connect without password correctly, with 7.3 Beta 2 (same pc same proxy configuration) I have the following error:
Cannot connect to: netcatcvstribe.cvs.sourceforge.net

I changed the priority to P2 because it's blocking the validation of NB 7.3.
Comment 3 marco76 2012-11-28 13:39:45 UTC
ok, my error ... my proxy was not ok ... it should be a problem with the password not a NB problem. I close the bug, I ll manage the specifications.
Comment 4 marco76 2012-12-03 12:27:26 UTC
The anonymous access should be possible but Netbeans fail to connect to the server for the checkout.
The bug announced by Divya should be reopened.
Other NetCat participants had the same issue.
Comment 5 Jiri Kovalsky 2012-12-03 12:32:44 UTC
For the record, it does not work from the command line either:

cesilko@cesilko-nb1 ~ $ cvs -d:pserver:anonymous@netcatcvstribe.cvs.sourceforge.net:/cvsroot/netcatcvstribe login
Logging in to :pserver:anonymous@netcatcvstribe.cvs.sourceforge.net:2401/cvsroot/netcatcvstribe
CVS password:
cvs [login aborted]: reading from server: Connection reset by peer
cesilko@cesilko-nb1 ~ $
Comment 6 Ondrej Vrabec 2012-12-03 13:06:46 UTC
> For the record, it does not work from the command line either:
marco: if it does not work from commandline, then what do you expect me to fix here? Can you try from commandline yourself and let me know if it works?
Comment 7 marco76 2012-12-04 06:15:07 UTC
The problem is with sourceforge:
http://sourceforge.net/blog/viewvc-and-anonymous-pserver-access-for-cvs-offline/

"Anonymous pserver is still offline. We’re working to get both these caught up with the latest updates as soon as we can."

With a different pserver is working correctly.

I close the bug.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo