Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 222870 - Find Usages and Search in Dependency with Attached Sources
Find Usages and Search in Dependency with Attached Sources
Status: RESOLVED DUPLICATE of bug 55291
Product: projects
Classification: Unclassified
Component: Libraries
7.2.1
PC Linux
: P3 with 1 vote (vote)
: TBD
Assigned To: Tomas Zezula
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 03:40 UTC by mintern
Modified: 2013-04-25 18:19 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mintern 2012-11-28 03:40:32 UTC
I am using Maven for dependency management. With some libraries, I find myself attaching and browsing the sources, especially when the Javadoc comments are not very thorough. This is great for jumping from my project code to a library's source, but once I get to there, it becomes difficult to navigate the library's source.

Navigate -> Go To Source works great, but Navigate -> Go To Implementation, Find Usages, and even a simple Find (e.g., right-click on the Dependency package and click Find...) do not work.

It would be immensely helpful if there was a way to use this functionality while browsing library source. I understand that searching all jars would negatively impact performance if it occurred all the time, but it would be nice to have (even if it's slow) specifically when initiating such a search from within a library's sources.
Comment 1 atr_23 2013-04-25 18:06:22 UTC
This issue seems to be a duplicate/reopen of #191334.

Although #191334 is marked as resolved, it does not work for me.
Comment 2 atr_23 2013-04-25 18:16:08 UTC
(In reply to comment #1)
> This issue seems to be a duplicate/reopen of #191334.
> 
> Although #191334 is marked as resolved, it does not work for me.

I think I misunderstood the bug. It seems to be a duplicate of Bug #55291.
Comment 3 atr_23 2013-04-25 18:19:49 UTC

*** This bug has been marked as a duplicate of bug 55291 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo