Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 222850 - [i18n] Unable to launch IDE in a folder with non-ascii characters
[i18n] Unable to launch IDE in a folder with non-ascii characters
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Launchers&CLI
7.2
PC Windows XP
: P3 (vote)
: 7.4
Assigned To: Libor Fischmeistr
issues@platform
:
Depends on:
Blocks: 223721
  Show dependency treegraph
 
Reported: 2012-11-27 16:53 UTC by jgodboldsmith
Modified: 2013-02-04 12:37 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
NB IDE launch error when in a folder with non-ascii characters (13.19 KB, image/jpeg)
2012-11-27 16:53 UTC, jgodboldsmith
Details
trace file for application launch (400 bytes, application/octet-stream)
2012-11-30 09:01 UTC, jgodboldsmith
Details
ubuntu log (4.11 KB, text/plain)
2012-12-06 16:41 UTC, Jiri Rechtacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jgodboldsmith 2012-11-27 16:53:08 UTC
Created attachment 128472 [details]
NB IDE launch error when in a folder with non-ascii characters

My organisation is developing a RCP application and during testing we've encountered an issue with trying to launch the application when it is installed into a folder containing non-ascii characters. 

When you execute the exe file you get the message: "Cannot find 'platform*' folder!"

Our app is installed using izPack and Java 7 (our installation doesn't work with Java 6 due to the JRE bug http://bugs.sun.com/view_bug.do?bug_id=4947220, which is fixed in J7 - I've seen reference to JRE bugs in previously logged issues here around this in bugzilla).


To disprove that the problem is with our RCP application I tried installing NB IDE into the same folder but it didn't work (I've logged this bug: http://netbeans.org/bugzilla/show_bug.cgi?id=222846).

Thereafter, I installed NB IDE into a valid folder location and copied the installation over to the folder containing the non-ascii characters. Upon launching I get message that the netbeans.clusters file cannot be read - see attachment.

Conclusion: is that NB cannot be installed or launched from a folder contained non-ascii characters.
Comment 1 Ondrej Vrabec 2012-11-29 10:03:30 UTC
Please attach the messages.log from the IDE startup: http://wiki.netbeans.org/FaqLogMessagesFile
Comment 2 jgodboldsmith 2012-11-29 11:49:17 UTC
unfortunately there is no log available, I don't think NB is getting far enough to be able to output anything to a log file. Only message, on screen, is:

'Cannot open file "C:\Temp\??\Netbeans7.2.1\etc\netbeans.clusters" for reading. The filename, directory name, or volume syntax is incorrect. (123)"

In the above message the ?? is the name of the folder containing the non-ascii characters. I would suggest you copy the NB IDE into a folder containing the same characters and try yourself, e.g.: C:\Temp\Съ

Thanks
Comment 3 Ondrej Vrabec 2012-11-30 08:39:06 UTC
libore, windows launcher has a switch to enable output to a file, i just don't remember the switch.
Comment 4 Libor Fischmeistr 2012-11-30 08:54:25 UTC
(In reply to comment #2)
> unfortunately there is no log available, I don't think NB is getting far enough
> to be able to output anything to a log file. Only message, on screen, is:

You are right NB don't start at all. The problem is, as I suppose, with Windows command prompt. CMD cannot deal with non-ascii folder names - generally withn non-ascii chars...

I would ask you for launcher log which could be very useful for us. Just run your app with --trace switch:

app.exe --trace trace.log

If there was some problem with it try to redirect log to some other folder without ascii chars:

app.exe --trace C:\Users\<username>\Documents\trace.log

Did you tried to launch app directly from bin folder or only via shortcut?
Comment 5 jgodboldsmith 2012-11-30 09:01:06 UTC
Created attachment 128621 [details]
trace file for application launch

Trace log file as per requested. This was created by executing shortcut (outside of the folder with the non-ascii characters) with the switch specified.
Comment 6 Jiri Rechtacek 2012-12-06 16:41:14 UTC
Created attachment 128994 [details]
ubuntu log

Confirmed on Ubuntu too I cannot start NetBeans by /tmp/žádný_netbeans/bin/netbeans

Caused by: While parsing jar:file:/tmp/žádný_netbeans/java/modules/org-netbeans-modules-java-editor.jar!/org/netbeans/modules/java/editor/resources/layer.xml
While parsing jar:file:/tmp/žádný_netbeans/ide/modules/org-netbeans-modules-defaults.jar!/org/netbeans/modules/defaults/mf-layer.xml
Caused: com.sun.org.apache.xerces.internal.util.URI$MalformedURIException: Opaque part contains invalid character: ž
Comment 7 Libor Fischmeistr 2012-12-12 13:41:26 UTC
(In reply to comment #6)
> Created attachment 128994 [details]
> ubuntu log
> 
> Confirmed on Ubuntu too I cannot start NetBeans by
> /tmp/žádný_netbeans/bin/netbeans
> 
> Caused by: While parsing
> jar:file:/tmp/žádný_netbeans/java/modules/org-netbeans-modules-java-editor.jar!/org/netbeans/modules/java/editor/resources/layer.xml
> While parsing
> jar:file:/tmp/žádný_netbeans/ide/modules/org-netbeans-modules-defaults.jar!/org/netbeans/modules/defaults/mf-layer.xml
> Caused: com.sun.org.apache.xerces.internal.util.URI$MalformedURIException:
> Opaque part contains invalid character: ž

This issue is not related to problem of this bug.

This bug is related to launcher and the problem on Ubuntu is related to Module System - Jirka will create new bug.

Also there is an umbrella task for all non-ascii related bugs - issue 223721

Decreasing priority.
Comment 8 Libor Fischmeistr 2013-01-31 13:53:31 UTC
Fixed in: http://hg.netbeans.org/core-main/rev/50a5e3d432ba

NetBeans IDE or platform app cannot be run from folder that contains non-ASCII chars in path.

The user gets error msg box and IDE won't start.
Comment 9 Libor Fischmeistr 2013-01-31 14:44:48 UTC
(In reply to comment #8)
> Fixed in: http://hg.netbeans.org/core-main/rev/50a5e3d432ba
> 
> NetBeans IDE or platform app cannot be run from folder that contains non-ASCII
> chars in path.
> 
> The user gets error msg box and IDE won't start.

Additional fix: http://hg.netbeans.org/core-main/rev/935c64685a2b

I missed space char...
Comment 10 Quality Engineering 2013-02-02 02:35:05 UTC
Integrated into 'main-golden', will be available in build *201302020001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/50a5e3d432ba
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #222850: [i18n] Unable to launch IDE in a folder with non-ascii characters


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo