Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 222846 - non-ascii characters in installation path
non-ascii characters in installation path
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
7.2.1
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Libor Fischmeistr
issues@installer
:
Depends on:
Blocks: 223721
  Show dependency treegraph
 
Reported: 2012-11-27 16:17 UTC by jgodboldsmith
Modified: 2015-03-26 13:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
log file from installer (57.39 KB, text/plain)
2012-11-27 16:17 UTC, jgodboldsmith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jgodboldsmith 2012-11-27 16:17:28 UTC
Created attachment 128470 [details]
log file from installer

Using the NB 7.2 installer, choose a folder location that contains non-ascii characters, e.g. C:\Temp\Съ

The installation begin to deflate the contents and then halts with an error, see attached log for further details
Comment 1 Libor Fischmeistr 2012-11-28 11:16:43 UTC
The problem is with the Windows command prompt that cannot deal with other chars than ASCII. As you can see from the log. The installation failed on the unpack command which is executed via command prompt... So this issue is relevant for all Windows versions. The installer otherwise doesn't have problem with non-ASCII chars.

The best practice is to do not use non-ASCII char in folder names :)
Comment 2 Jiri Rechtacek 2012-12-06 16:48:21 UTC
On Ubuntu I can the IDE install to non-ascii folder - running the installer both on JDK 7 and on JDK 6 Update 38.
Comment 3 Libor Fischmeistr 2013-01-30 08:44:49 UTC
The fist fix in changeset: http://hg.netbeans.org/core-main/rev/2ed0df350708

Just for NetBeans IDE installer.

Now the user cannot install IDE to installation path with non-ASCII char.

The same has to be done for RCP app installer.
Comment 4 Libor Fischmeistr 2013-01-30 13:24:50 UTC
Fix for RCP applications installer: http://hg.netbeans.org/core-main/rev/6c6a5d44fd18
Comment 5 Quality Engineering 2013-01-31 03:13:45 UTC
Integrated into 'main-golden', will be available in build *201301310001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2ed0df350708
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #222846: non-ascii characters in installation path
Comment 6 stophi 2014-07-30 07:05:56 UTC
(In reply to Libor Fischmeistr from comment #1)
> The problem is with the Windows command prompt that cannot deal with other
> chars than ASCII. 

I think this statement is not true for all non-ascii characters. Windows command prompt can handle some non-ascii characters. I do not know the preconditions and set of characters that are allowed, but on my machine, Windows command prompt can handle e.g. German umlauts, such as 'ä', 'ö' and 'ü'.

With NetBeans 7.3, it was possible to install NetBeans (and NetBeans Platform based applications) to 'C:\äöü' and start from there, with NetBeans 7.3.1, this is not possible anymore. 

The users of my NB-Platform-based Application used to do that. So I see this as an incompatible change. I would suggest to rework the bugfix so that a wider range than just the 7-Bit ASCII range is allowed to use.
Comment 7 Libor Fischmeistr 2015-03-26 13:21:10 UTC
Consider this bug fixed. Please do not reopen, rather file new issue.

Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo