Bug 222700 - IllegalStateException: No instance created for service org.netbeans.modules.web.javascript.debugger.actions.DebuggerActionsProvider, context = null, path = Debugger/javascript-debuggerengine/org-netbe
IllegalStateException: No instance created for service org.netbeans.modules.w...
Status: RESOLVED FIXED
Product: javascript
Classification: Unclassified
Component: Debugger
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Martin Entlicher
issues@javascript
EXCEPTIONS_REPORT
:
: 224151 224543 (view as bug list)
Depends on:
Blocks: 223576
  Show dependency treegraph
 
Reported: 2012-11-24 20:20 UTC by zdenek.rod
Modified: 2013-08-08 07:01 UTC (History)
13 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.23 KB, text/plain)
2012-11-24 20:20 UTC, zdenek.rod
Details
stacktrace (3.23 KB, text/plain)
2012-11-27 17:59 UTC, lehel
Details
stacktrace (3.23 KB, text/plain)
2012-12-03 09:02 UTC, Petr Jiricka
Details
stacktrace (3.23 KB, text/plain)
2013-04-24 13:58 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zdenek.rod 2012-11-24 20:20:53 UTC
Build: NetBeans IDE Dev (Build 201211200002)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows 7

User Comments:
drethic: I was doing the initial load in after installing, got prompted to import 2 plugins and then recieved this error.

zdenek.rod: I instaled some plugins from availible plugins.

slapo: The problem occurred when I let NetBeans reinstall the Subversion plug-in.

reinouts: Importing plugins from previous Netbeans installation




Stacktrace: 
java.lang.IllegalStateException: No instance created for service org.netbeans.modules.web.javascript.debugger.actions.DebuggerActionsProvider, context = null, path = Debugger/javascript-debuggerengine/org-netbeans-modules-web-javascript-debugger-actions-DebuggerActionsProvider.instance
   at org.netbeans.spi.debugger.ActionsProvider$ContextAware.getDelegate(ActionsProvider.java:220)
   at org.netbeans.spi.debugger.ActionsProvider$ContextAware.getActions(ActionsProvider.java:241)
   at org.netbeans.api.debugger.ActionsManager.registerActionsProviders(ActionsManager.java:482)
   at org.netbeans.api.debugger.ActionsManager.access$800(ActionsManager.java:64)
   at org.netbeans.api.debugger.ActionsManager$3.propertyChange(ActionsManager.java:497)
   at org.netbeans.api.debugger.Lookup$MetaInf$MetaInfLookupList.firePropertyChange(Lookup.java:953)
Comment 1 zdenek.rod 2012-11-24 20:20:56 UTC
Created attachment 128347 [details]
stacktrace
Comment 2 Martin Entlicher 2012-11-27 13:56:28 UTC
I'm unfortunately not able to reproduce this. The exception comes from some inconsistent state, that should not occur.
To get more information, I've added some logging in
changeset:   241077:fa91f4a8d497
http://hg.netbeans.org/core-main/rev/fa91f4a8d497

Please provide some concrete steps how to reproduce this, if you can. Thanks.
Comment 3 lehel 2012-11-27 17:59:28 UTC
Created attachment 128474 [details]
stacktrace

Webclient testing:
-Adding the plugin for Vaadin framework:
http://plugins.netbeans.org/plugin/21965/vaadinframework
Comment 4 Quality Engineering 2012-11-29 02:33:23 UTC
Integrated into 'main-golden', will be available in build *201211290002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/67f89b456c35
User: mentlicher@netbeans.org
Log: #222700 Print the context as well, when the service creation fails.
Comment 5 Petr Jiricka 2012-12-03 09:02:34 UTC
Created attachment 128750 [details]
stacktrace

After installation of Tim Boudreau's Node.js plugin, but I am not sure if it's related to this plugin.
Comment 6 Petr Jiricka 2012-12-03 09:06:13 UTC
> I'm unfortunately not able to reproduce this.

Martin, I was able to reproduce as follows:
1. Started a fresh build with ergonomics with empty userdir
2. Activated HTML5 features by going to New Project -> HTML5 project and then Cancel
3. Installed this plugin: http://timboudreau.com/files/nodejs-2.0.nbm using Plugin manager's Downloaded tab
Comment 7 Martin Entlicher 2012-12-05 14:00:52 UTC
The log suggests, that PathLookupResult does not work correctly, however, I'm still not able to reproduce this, unfortunately. Will keep investigating...
Comment 8 Vladimir Voskresensky 2012-12-11 08:23:38 UTC
Martin, after recent logging we have NPE in 
java.lang.NullPointerException
	at org.netbeans.api.debugger.ActionsManager.registerActionsProviders(ActionsManager.java:500)


See
http://deadlock.netbeans.org/hudson/job/push-cnd-main/25742/testReport/junit/org.netbeans.core.windows.awt/ValidateLayerToolbarTest/testContentCorrect/
Comment 9 Vladimir Voskresensky 2012-12-11 08:25:48 UTC
btw, ActionsManager.aps is not final field. Is it guaranteed to be inited only once and visible same way from different threads? If not then it might be incorrect to use it as syn-lock object in registerActionsProviders method
Comment 10 Vladimir Voskresensky 2012-12-11 08:28:49 UTC
I pushed fix for NPE to allow pass of push-cnd-main job.
http://hg.netbeans.org/cnd-main/rev/0680b33b10ed
Comment 11 henk89 2012-12-11 10:19:08 UTC
*** Bug 223576 has been marked as a duplicate of this bug. ***
Comment 12 Exceptions Reporter 2012-12-17 13:53:15 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=193049
Comment 13 Martin Entlicher 2013-01-08 10:50:19 UTC
*** Bug 224543 has been marked as a duplicate of this bug. ***
Comment 14 Martin Entlicher 2013-01-08 17:24:15 UTC
*** Bug 224151 has been marked as a duplicate of this bug. ***
Comment 15 Jiri Kovalsky 2013-04-24 13:58:16 UTC
Created attachment 133753 [details]
stacktrace

Launched IDE, opened sample web project, installed CVS and JUnit plugins when this happened.
Comment 16 Martin Entlicher 2013-08-08 07:01:40 UTC
No reports from 7.4, thus it was hopefully fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo