Bug 222651 - IDE freezes (must be killed)
IDE freezes (must be killed)
Status: RESOLVED DUPLICATE of bug 222538
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.3
PC Windows 7 x64
: P2 (vote)
: 7.3
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 10:28 UTC by akobberup
Modified: 2012-11-26 15:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
threaddump of the ide after it had locked up.. (43.26 KB, application/octet-stream)
2012-11-23 10:28 UTC, akobberup
Details

Note You need to log in before you can comment on or make changes to this bug.
Description akobberup 2012-11-23 10:28:20 UTC
Created attachment 128302 [details]
threaddump of the ide after it had locked up..

I have experienced this two times now (in build 201211170002) this time i took a thread dump.

For me it seems to be maybe a deadlock in the editor or something like that..


"AWT-EventQueue-1" prio=6 tid=0x0000000012ee9800 nid=0x157c in Object.wait() [0x00000000106bd000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java:503)
	at javax.swing.text.AbstractDocument.readLock(AbstractDocument.java:1387)
	- locked <0x00000000d6e95960> (a org.netbeans.modules.editor.NbEditorDocument)
Comment 1 Milutin Kristofic 2012-11-26 12:20:19 UTC
AWT-EventQueue-1 is blocking codetemplates and waiting for Document.Readlock

"Module-Actions" is blocking editor runAtomicAsUser and waiting for codetemplates.
Comment 2 Dusan Balek 2012-11-26 15:48:36 UTC
Already fixed.

*** This bug has been marked as a duplicate of bug 222538 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo