Bug 222550 - NullPointerException at com.oracle.nashorn.ir.LiteralNode.equals
NullPointerException at com.oracle.nashorn.ir.LiteralNode.equals
Status: RESOLVED FIXED
Product: javascript
Classification: Unclassified
Component: -- Other --
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Petr Hejl
issues@javascript
http://kenai.com/jira/browse/NASHORN-744
EXCEPTIONS_REPORT
:
: 223816 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 14:41 UTC by ktm
Modified: 2012-12-17 11:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.44 KB, text/plain)
2012-11-21 14:41 UTC, ktm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ktm 2012-11-21 14:41:20 UTC
Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-ea-b15
OS: Mac OS X

User Comments:
ktm: Launching a web app (a vaadin UI) into tomcat 7 from the IDE.




Stacktrace: 
java.lang.NullPointerException
   at com.oracle.nashorn.ir.LiteralNode.equals(LiteralNode.java:80)
   at com.oracle.nashorn.ir.UnaryNode.equals(UnaryNode.java:105)
   at com.oracle.nashorn.ir.BinaryNode.equals(BinaryNode.java:105)
   at com.oracle.nashorn.ir.BinaryNode.equals(BinaryNode.java:108)
   at com.oracle.nashorn.ir.TernaryNode.equals(TernaryNode.java:62)
   at com.oracle.nashorn.ir.UnaryNode.equals(UnaryNode.java:105)
Comment 1 ktm 2012-11-21 14:41:22 UTC
Created attachment 128213 [details]
stacktrace
Comment 2 Petr Hejl 2012-11-26 10:27:46 UTC
Should be fixed in web-main 498d16481446.
Comment 3 Martin Fousek 2012-12-17 11:08:39 UTC
*** Bug 223816 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo