Bug 222485 - IllegalStateException: Too many repetitions in getNodes(true). Giving up.
IllegalStateException: Too many repetitions in getNodes(true). Giving up.
Status: RESOLVED DUPLICATE of bug 221279
Product: platform
Classification: Unclassified
Component: Nodes
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 16:59 UTC by Antonin Nebuzelsky
Modified: 2012-11-23 08:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.09 KB, text/plain)
2012-11-20 16:59 UTC, Antonin Nebuzelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2012-11-20 16:59:15 UTC
Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-ea-b14
OS: Linux

User Comments:
anebuzelsky: Invoked Ctrl+Shift+3 on an HTML file in editor to navigate to the file in Favorites. The exception was raised and the action failed




Stacktrace: 
java.lang.IllegalStateException: Too many repetitions in getNodes(true). Giving up.
   at org.openide.loaders.FolderChildren.getNodes(FolderChildren.java:288)
   at org.openide.nodes.FilterNode$Children$LazySupport.callGetNodes(FilterNode.java:1767)
   at org.openide.nodes.FilterNode$Children.getNodes(FilterNode.java:1606)
   at org.netbeans.modules.favorites.Tab.findDataObject(Tab.java:474)
   at org.netbeans.modules.favorites.Tab.findClosestNode(Tab.java:411)
   at org.netbeans.modules.favorites.Tab.selectNode(Tab.java:448)
Comment 1 Antonin Nebuzelsky 2012-11-20 16:59:18 UTC
Created attachment 128154 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-11-23 08:01:34 UTC
I need report at least with revision 4d4e7830aa10, but this report is for older version:

$ hg log -r 'ancestor(4b9ddecda013,4d4e7830aa10)'
changeset:   245578:0675dff5ae9a
tag:         release73_beta2_base
parent:      245565:db7473b0d630
parent:      245577:f42ad4cbd723
user:        ffjre@netbeans.org
date:        Thu Nov 01 06:03:40 2012 +0000
summary:     Merge of http://hg.netbeans.org/core-main/

*** This bug has been marked as a duplicate of bug 221279 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo