Bug 222189 - IDE got stuck while drag and drop to copy file
IDE got stuck while drag and drop to copy file
Status: RESOLVED DUPLICATE of bug 221279
Product: platform
Classification: Unclassified
Component: Explorer
7.2
PC Windows 7 x64
: P3 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 09:55 UTC by Alexander Kouznetsov
Modified: 2012-11-19 09:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stack Dump (16.90 KB, text/plain)
2012-11-15 09:55 UTC, Alexander Kouznetsov
Details
Screenshot (9.40 KB, image/png)
2012-11-15 09:57 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2012-11-15 09:55:35 UTC
Created attachment 127848 [details]
Stack Dump

I got IDE stuck when doing drag and drop of a file to copy it.

Here is a part of stack dump:

"AWT-EventQueue-1" prio=6 tid=0x00000000114e0800 nid=0x1348 runnable [0x000000001095d000]
   java.lang.Thread.State: RUNNABLE
	at org.openide.loaders.FolderChildren.waitOptimalResult(FolderChildren.java:295)
	at org.openide.loaders.FolderChildren.getNodes(FolderChildren.java:262)
	at org.openide.nodes.FilterNode$Children$LazySupport.callGetNodes(FilterNode.java:1767)
	at org.openide.nodes.FilterNode$Children.getNodes(FilterNode.java:1606)
	at org.openide.explorer.view.TreeViewDropSupport.drop(TreeViewDropSupport.java:770)
	at java.awt.dnd.DropTarget.drop(DropTarget.java:450)
	- locked <0x00000000d231f598> (a java.awt.dnd.DropTarget)
	at sun.awt.dnd.SunDropTargetContextPeer.processDropMessage(SunDropTargetContextPeer.java:537)
	at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchDropEvent(SunDropTargetContextPeer.java:851)
	- locked <0x00000000da2f84f0> (a sun.awt.windows.WDropTargetContextPeer)
Comment 1 Alexander Kouznetsov 2012-11-15 09:57:05 UTC
Created attachment 127850 [details]
Screenshot
Comment 2 Jaroslav Tulach 2012-11-19 09:05:01 UTC
CPU at 100%? There is a bug in FolderChildren.getNodes(true) which I am trying to track down via logs.

*** This bug has been marked as a duplicate of bug 221279 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo