Bug 222077 - AssertionError: Debugger lock taken in AWT Event Queue!
AssertionError: Debugger lock taken in AWT Event Queue!
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 23:03 UTC by Chiana
Modified: 2012-11-26 11:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.88 KB, text/plain)
2012-11-13 23:03 UTC, Chiana
Details
stacktrace (1.88 KB, text/plain)
2012-11-13 23:29 UTC, Chiana
Details
Screenshot (119.33 KB, image/jpeg)
2012-11-13 23:36 UTC, Chiana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chiana 2012-11-13 23:03:08 UTC
This bug was originally marked as duplicate of bug 159006, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201211130001)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7

User Comments:
Chiana: and again... Restarting IDE.

Chiana: After reporting #628786 tried again to debug but this occured.




Stacktrace: 
java.lang.AssertionError: Debugger lock taken in AWT Event Queue!
   at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl$DebuggerReentrantReadWriteLock$DebuggerReadLock.lock(JPDADebuggerImpl.java:2381)
   at org.netbeans.modules.debugger.jpda.models.JPDAThreadImpl$ThreadReentrantReadWriteLock$ThreadWriteLock.lock(JPDAThreadImpl.java:2267)
   at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.invokeMethod(JPDADebuggerImpl.java:980)
   at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.invokeMethod(JPDADebuggerImpl.java:962)
   at org.netbeans.modules.debugger.jpda.expr.InvocationExceptionTranslated.getLocalizedMessage(InvocationExceptionTranslated.java:151)
   at org.netbeans.core.NbErrorManager$Exc.getLocalizedMessage(NbErrorManager.java:236)
Comment 1 Chiana 2012-11-13 23:03:09 UTC
Created attachment 127746 [details]
stacktrace
Comment 2 Chiana 2012-11-13 23:29:31 UTC
Created attachment 127749 [details]
stacktrace

Seems this is occuring when creating a modal JDialog splash on the system desktop, I will look further to see if it is possible to pindown where this occurs and what is beeing done at the moment.
Attaching screendump showing set bp's and current PC.
Comment 3 Chiana 2012-11-13 23:36:13 UTC
Created attachment 127750 [details]
Screenshot

Showing code snip where initially detected.
Comment 4 Chiana 2012-11-13 23:44:29 UTC
Regression
Comment 5 Chiana 2012-11-13 23:52:14 UTC
This might be related to the installed securitymanager, I commented that one out and it worked.
Comment 6 Martin Entlicher 2012-11-14 14:16:06 UTC
This is a problem in code, which was added to log the cause of issue #217048.
This problem is fixed by changeset:   239909:37f910cb0ed6
http://hg.netbeans.org/core-main/rev/37f910cb0ed6
Comment 7 Quality Engineering 2012-11-16 02:41:04 UTC
Integrated into 'main-golden', will be available in build *201211160001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/37f910cb0ed6
User: mentlicher@netbeans.org
Log: #222077: Initialize the InvocationExceptionTranslated after the thread is notified about finish of method invocation.
Comment 8 Chiana 2012-11-26 11:56:10 UTC
Verified 20121126


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo