Bug 222040 - com.tasktop.c2c.server.common.service.ValidationException: Invalid query.
com.tasktop.c2c.server.common.service.ValidationException: Invalid query.
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: ODCS Tasks
7.3
All All
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@ide
EXCEPTIONS_REPORT
:
: 222819 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 12:36 UTC by Tomas Stupka
Modified: 2012-11-28 13:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.77 KB, text/plain)
2012-11-13 12:36 UTC, Tomas Stupka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2012-11-13 12:36:12 UTC
Build: NetBeans IDE Dev (Build 20121112-4754f277758a)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.12-b01-434, Java(TM) SE Runtime Environment, 1.6.0_37-b06-434-11M3909
OS: Mac OS X

User Comments:
tstupka: tried to save a query where Created Start: 2012-01-01 End: 2012-02-02




Stacktrace: 
com.tasktop.c2c.server.common.service.ValidationException: Invalid query.
   at com.tasktop.c2c.server.common.service.web.Error.getException(Error.java:216)
   at com.tasktop.c2c.server.common.service.web.ServiceResponseErrorHandler.handleError(ServiceResponseErrorHandler.java:67)
   at org.springframework.web.client.RestTemplate.handleResponseError(RestTemplate.java:486)
   at org.springframework.web.client.RestTemplate.doExecute(RestTemplate.java:443)
   at org.springframework.web.client.RestTemplate.execute(RestTemplate.java:401)
   at org.springframework.web.client.RestTemplate.postForObject(RestTemplate.java:279)
Comment 1 Tomas Stupka 2012-11-13 12:36:14 UTC
Created attachment 127714 [details]
stacktrace
Comment 2 Tomas Stupka 2012-11-13 13:56:35 UTC
also can't read a query containing date criteria

java.lang.IllegalStateException: Illegal literal near offset 32: >
	at com.tasktop.c2c.server.common.service.domain.criteria.CriteriaParser.parse(CriteriaParser.java:132)
	at com.tasktop.c2c.server.common.service.domain.criteria.CriteriaParser.parse(CriteriaParser.java:26)
	at com.tasktop.c2c.server.tasks.domain.SavedTaskQuery.getQueryCriteria(SavedTaskQuery.java:50)
Comment 3 Tomas Stupka 2012-11-13 15:34:44 UTC
outdated com.tasktop.c2c.server.xxx packages
need upgrade
Comment 4 Tomas Stupka 2012-11-27 17:43:50 UTC
*** Bug 222819 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Stupka 2012-11-28 13:12:53 UTC
fixed in core-main #9d9b40e303c1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo