Bug 221940 - [73cat] IDE frozen while organizing imports
[73cat] IDE frozen while organizing imports
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Logger
7.3
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Martin Entlicher
logger-issues@ide
:
: 221061 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-12 10:19 UTC by misterm
Modified: 2012-12-26 18:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (22.85 KB, text/plain)
2012-11-12 10:20 UTC, misterm
Details
messages.log (25.71 KB, application/octet-stream)
2012-11-12 10:20 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2012-11-12 10:19:29 UTC
Was just calling organize imports on a project I was working on.

Product Version = NetBeans IDE Dev (Build 20121111-9e5f3cd6ae05)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_07
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.3-b01
Comment 1 misterm 2012-11-12 10:20:45 UTC
Created attachment 127601 [details]
thread dump
Comment 2 misterm 2012-11-12 10:20:50 UTC
Created attachment 127602 [details]
messages.log
Comment 3 Dusan Balek 2012-11-12 18:26:17 UTC
As can be seen from the attached thread dump, the only activity comes fro UI Handler. Reassigning.
Comment 4 Martin Entlicher 2012-11-18 11:25:03 UTC
AWT is blocked by UIHandler.waitFlushed(UIHandler.java:183)
Comment 5 Martin Entlicher 2012-11-19 14:26:02 UTC
Fixed by changeset:   240279:9fe300880a9f
http://hg.netbeans.org/core-main/rev/9fe300880a9f
Comment 6 Quality Engineering 2012-11-21 13:39:07 UTC
Integrated into 'main-golden', will be available in build *201211211016* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9fe300880a9f
User: mentlicher@netbeans.org
Log: #221940: Count the log records in an RP thread.
Comment 7 Martin Entlicher 2012-12-10 16:09:23 UTC
*** Bug 221061 has been marked as a duplicate of this bug. ***
Comment 8 Ondrej Vrabec 2012-12-26 18:50:42 UTC
*** Bug 224114 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo