Bug 221817 - Cannot initialize 0th child of node db.explorer.node.CatalogNode
Cannot initialize 0th child of node db.explorer.node.CatalogNode
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Jaroslav Havlin
issues@db
EXCEPTIONS_REPORT
:
: 221839 221915 221948 221977 222034 222036 222049 222206 222207 222310 223919 225405 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 12:59 UTC by Martin Fousek
Modified: 2013-01-28 12:39 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (11.96 KB, text/plain)
2012-11-09 12:59 UTC, Martin Fousek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Fousek 2012-11-09 12:59:19 UTC
Build: NetBeans IDE Dev (Build 20121109-78747b9551da)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.0-b09, Java(TM) SE Runtime Environment, 1.6.0_23-b05
OS: Linux

User Comments:
marfous: 1, created new DB
2, connected to it
->exception appeared




Stacktrace: 
java.lang.IllegalStateException: Cannot initialize 0th child of node org.netbeans.modules.db.explorer.node.CatalogNode@72809308[Name=Default, displayName=Default]; it already belongs to node org.netbeans.modules.db.explorer.node.ConnectionNode@6d1ea615[Name=jdbc:derby://localhost:1527/simpledb [app on APP], displayName=jdbc:derby://localhost:1527/simpledb [app on APP]] (did you forgot to use cloneNode?)
Children of new node: null
Children of old node: null
   at org.openide.nodes.Node.assignTo(Node.java:354)
   at org.openide.nodes.EntrySupportDefault.justComputeNodes(EntrySupportDefault.java:212)
   at org.openide.nodes.ChildrenArray.nodes(ChildrenArray.java:88)
   at org.openide.nodes.EntrySupportDefault.getNodes(EntrySupportDefault.java:130)
   at org.openide.nodes.EntrySupportDefault.getNodes(EntrySupportDefault.java:172)
   at org.openide.nodes.Children.getNodes(Children.java:469)
Comment 1 Martin Fousek 2012-11-09 12:59:21 UTC
Created attachment 127463 [details]
stacktrace
Comment 2 Jaroslav Havlin 2012-11-09 17:55:44 UTC
*** Bug 221839 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslav Havlin 2012-11-12 14:23:37 UTC
*** Bug 221948 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Havlin 2012-11-12 14:53:17 UTC
http://hg.netbeans.org/core-main/rev/0c9de3ddbd5c
Fixed. Thank you for reporting. Please verify.
Comment 5 Jaroslav Havlin 2012-11-13 12:33:03 UTC
*** Bug 222036 has been marked as a duplicate of this bug. ***
Comment 6 Jaroslav Havlin 2012-11-14 07:45:43 UTC
*** Bug 221977 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Havlin 2012-11-14 07:52:31 UTC
*** Bug 222034 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Havlin 2012-11-14 08:00:46 UTC
*** Bug 222049 has been marked as a duplicate of this bug. ***
Comment 9 Sergey Petrov 2012-11-14 09:43:41 UTC
why it's not propaged yet even to main-silver?
it almost block any activity with db, even in persistence wizards.
Comment 10 Jaroslav Havlin 2012-11-14 09:50:50 UTC
(In reply to comment #9)
> why it's not propaged yet even to main-silver?
Job push-core-main is failing. It's already being solved.
Comment 11 Quality Engineering 2012-11-15 02:47:09 UTC
Integrated into 'main-golden', will be available in build *201211150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0c9de3ddbd5c
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #221817: Cannot initialize 0th child of node db.explorer.node.CatalogNode
Comment 12 Jaroslav Havlin 2012-11-15 13:31:25 UTC
*** Bug 222207 has been marked as a duplicate of this bug. ***
Comment 13 Jaroslav Havlin 2012-11-19 07:55:49 UTC
*** Bug 221915 has been marked as a duplicate of this bug. ***
Comment 14 Jaroslav Havlin 2012-11-19 07:56:31 UTC
*** Bug 222206 has been marked as a duplicate of this bug. ***
Comment 15 Jaroslav Havlin 2012-11-19 09:51:28 UTC
*** Bug 222310 has been marked as a duplicate of this bug. ***
Comment 16 Jaroslav Havlin 2012-12-17 13:16:43 UTC
*** Bug 223919 has been marked as a duplicate of this bug. ***
Comment 17 Petr Cyhelsky 2013-01-28 12:39:19 UTC
*** Bug 225405 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo