Bug 221585 - LowPerformance took 3021 ms.
LowPerformance took 3021 ms.
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 21:29 UTC by ercee
Modified: 2012-11-22 09:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (16.97 KB, application/nps)
2012-11-06 21:29 UTC, ercee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ercee 2012-11-06 21:29:46 UTC
This bug was originally marked as duplicate of bug 194559, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta (Build 201210011125)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b20
OS: Mac OS X
Maximum slowness yet reported was 3021 ms, average is 3021
Comment 1 ercee 2012-11-06 21:29:48 UTC
Created attachment 127260 [details]
nps snapshot
Comment 2 Dusan Balek 2012-11-13 08:41:08 UTC
Seems like a JDK problem - 8 calls to
java.awt.FontMetrics.getStringBounds(...) took 2890 ms (as can be seen from the
attached NPS snapshot).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo