Bug 221375 - Find action at Output view does not have Ctrl+F shortcut anymore
Find action at Output view does not have Ctrl+F shortcut anymore
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.3
PC Linux
: P2 (vote)
: 7.3
Assigned To: Jaroslav Havlin
issues@platform
: 73_HR_FIX
: 221753 221961 222078 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 17:15 UTC by Michel Graciano
Modified: 2013-01-25 10:25 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2012-11-02 17:15:43 UTC
[ BUILD # : fbf3a3f13f00 ]
[ JDK VERSION : 1.7.9 ]

If I call Ctrl+F shortcut at Output view (with text), the Find in Project is
called instead Find (in Output).
Comment 1 Jaroslav Havlin 2012-11-06 13:09:21 UTC
I was able to reproduce only using these scenario:

 - Clean and build a project
 - View IDE Log (2 output tabs are open)
 - Click one of the two tabs (not inside the text panel, the tab only)
 - Press Ctrl+F
 - Find in Projects dialog was opened.
 
This is fixed in http://hg.netbeans.org/core-main/rev/d12fa19e2bec

Otherwise, it works fine for me.

Please verify that it works fine correctly for you, or add exact steps to reproduce and reopen.
Thank you.
Comment 2 Michel Graciano 2012-11-06 13:27:47 UTC
I will verify as soon as it hits main-golden. BTW, about reproduce it, I can't with Beta 2 build but for 20121102-4289cf966928 (I did it locally), I can reproduce it.

1. Opem the IDE;
2. View > IDE log;
3. Put the cursor at any part of the text and hit Ctrl + F, the 'Find in Projects' view is opened.

The same happen if I build any project (or not).

Anyway, lets wait for it hits main-golden and I recheck it. Thanks for the fix :)
Comment 3 Quality Engineering 2012-11-07 03:43:44 UTC
Integrated into 'main-golden', will be available in build *201211070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d12fa19e2bec
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #221375: Find action at Output view does not have Ctrl+F shortcut anymore
Comment 4 Jaroslav Havlin 2012-11-09 08:22:33 UTC
*** Bug 221753 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Havlin 2012-11-09 09:01:08 UTC
(In reply to comment #4)
> *** Bug 221753 has been marked as a duplicate of this bug. ***
Reproduced on build 20121108-072e09263b07.
Seems to occur randomly. Needs further investigation. Reopening.
Comment 6 Michel Graciano 2012-11-09 11:31:48 UTC
I have tested with build 20121109-beb7bf2aea3f (I just did it) and can't reproduce it anymore. I will keep using it, but for me, it looks fixed.
Comment 7 Jaroslav Havlin 2012-11-12 13:48:37 UTC
*** Bug 221961 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Havlin 2012-11-12 15:57:44 UTC
http://hg.netbeans.org/core-main/rev/a610cbed6593

I've realized that incorrect action id had been used.
The shortcut is now also displayed in the pop-up menu.
The issue is hopefully fixed. Please reopen again if you can still reproduce it.
Thank you.
Comment 9 Jaroslav Havlin 2012-11-14 10:24:29 UTC
*** Bug 222078 has been marked as a duplicate of this bug. ***
Comment 10 Quality Engineering 2012-11-15 02:48:28 UTC
Integrated into 'main-golden', will be available in build *201211150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a610cbed6593
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #221375: Update id for Find action
Comment 11 Michel Graciano 2012-11-19 13:00:23 UTC
v. Build 20121119-3b34dfd7e17e
Comment 12 Jaroslav Havlin 2013-01-11 09:42:34 UTC
I can reproduce the bug again. Reopening. Increasing priority, as it is a regression.
Comment 13 _ tboudreau 2013-01-11 09:46:25 UTC
Yup, it's back.
Comment 14 Jaroslav Havlin 2013-01-11 09:47:54 UTC
The Find action id has to be modified again.
Fixed in http://hg.netbeans.org/core-main/rev/879bce3176ce
Please verify.
Comment 15 Quality Engineering 2013-01-12 02:53:40 UTC
Integrated into 'main-golden', will be available in build *201301120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/879bce3176ce
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #221375: Update id for Find action once more
Comment 16 Tomas Danek 2013-01-14 10:58:15 UTC
cannot reproduce in 

Product Version: NetBeans IDE Dev (Build 201301140001)
Java: 1.6.0_27; Java HotSpot(TM) Client VM 20.2-b06
Runtime: Java(TM) SE Runtime Environment 1.6.0_27-b07
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
User directory: C:\Users\tester\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\tester\AppData\Local\NetBeans\Cache\dev

-> verified in trunk.
Comment 17 Jaroslav Havlin 2013-01-15 10:26:33 UTC
(In reply to comment #16)
> -> verified in trunk.
Thank you very much.

Integrated into release73:
http://hg.netbeans.org/releases/rev/d366cb04f023
Comment 18 Quality Engineering 2013-01-16 00:01:32 UTC
Integrated into 'releases', will be available in build *201301152100* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/d366cb04f023
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #221375: Update id for Find action once more
Comment 19 Tomas Danek 2013-01-25 10:25:41 UTC
I haven't been able to reproduce in 

Product Version: NetBeans IDE 7.3 RC1 (Build 201301232200)
Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Mac OS X version 10.8.2 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.3rc1
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.3rc1

--> verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo