Bug 221324 - IllegalArgumentException at java.nio.Buffer.position
IllegalArgumentException at java.nio.Buffer.position
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
7.3
All All
: P2 (vote)
: 8.0
Assigned To: Theofanis Oikonomou
issues@platform
EXCEPTIONS_REPORT
:
: 227433 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 09:47 UTC by Alexander Simon
Modified: 2014-02-19 02:44 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.81 KB, text/plain)
2012-11-02 09:47 UTC, Alexander Simon
Details
stacktrace (3.93 KB, text/plain)
2012-11-02 10:53 UTC, Alexander Simon
Details
stacktrace (3.93 KB, text/plain)
2012-11-02 13:26 UTC, Alexander Simon
Details
stacktrace (2.94 KB, text/plain)
2013-03-14 17:42 UTC, Exceptions Reporter
Details
patch (1.09 KB, patch)
2014-02-18 10:45 UTC, Theofanis Oikonomou
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2012-11-02 09:47:47 UTC
Build: NetBeans IDE Dev (Build 20121102-e599cc9f2072)
VM: Java HotSpot(TM) Client VM, 20.8-b03, Java(TM) SE Runtime Environment, 1.6.0_33-b03
OS: SunOS

Stacktrace: 
java.lang.IllegalArgumentException
   at java.nio.Buffer.position(Buffer.java:216)
   at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:583)
   at org.netbeans.api.queries.FileEncodingQuery$ProxyCharset$ProxyDecoder.decodeLoop(FileEncodingQuery.java:210)
   at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:544)
   at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:298)
   at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:158)
Comment 1 Alexander Simon 2012-11-02 09:47:49 UTC
Created attachment 126976 [details]
stacktrace
Comment 2 Alexander Simon 2012-11-02 10:53:07 UTC
Created attachment 126985 [details]
stacktrace
Comment 3 Alexander Simon 2012-11-02 13:26:07 UTC
Created attachment 127002 [details]
stacktrace
Comment 4 Exceptions Reporter 2013-03-14 17:42:42 UTC
Created attachment 132619 [details]
stacktrace
Comment 5 Milos Kleint 2013-03-20 14:13:02 UTC
*** Bug 227433 has been marked as a duplicate of this bug. ***
Comment 6 Exceptions Reporter 2013-08-07 08:17:13 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=194431
Comment 7 Antonin Nebuzelsky 2013-12-27 14:28:55 UTC
Fanis, please take this one.
Comment 8 Exceptions Reporter 2014-02-18 03:46:30 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=194431
Comment 9 Theofanis Oikonomou 2014-02-18 10:45:25 UTC
Created attachment 145347 [details]
patch

Only 5 of the reports do not come from TodoTaskScanner and none of them are from beta or dev builds. All the rest reports come from TodoTaskScanner.

I am not sure what is the root of the issue but I guess is the way the buffer is read into from org.netbeans.api.queries.FileEncodingQuery$ProxyCharset$ProxyDecoder.decodeLoop

I am attaching a fix. Honzo, if you are ok with it I will push the fix
Comment 10 Theofanis Oikonomou 2014-02-18 11:14:54 UTC
Changeset: adae2c1c5e4c
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2014-02-18 12:16
Message:
Comment 11 Theofanis Oikonomou 2014-02-18 11:16:55 UTC
TodoTaskScanner handles the situation more gracefully now. The problem might still be present in org.netbeans.api.queries.FileEncodingQuery$ProxyCharset$ProxyDecoder.decodeLoop I guess...
Comment 12 Quality Engineering 2014-02-19 02:44:43 UTC
Integrated into 'main-silver', will be available in build *201402190001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/adae2c1c5e4c
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Task #221324 - IllegalArgumentException at java.nio.Buffer.position


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo