Bug 221312 - "Add Existing Item..." menu item doesn't work
"Add Existing Item..." menu item doesn't work
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.3
PC Solaris
: P1 (vote)
: 7.3
Assigned To: Alexander Simon
issues@cnd
73beta2-stopper-verified
:
: 221313 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 07:16 UTC by soldatov
Modified: 2012-11-06 14:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2012-11-02 07:16:32 UTC
Scenario:
- Create C/C++ Application project
- Select Source Files node
- Call context menu. Select "Add Existing Item..." menu item.
- Select some external C/C++ file
- Press Select button
===>
No new files in project
Comment 1 Alexander Simon 2012-11-02 08:38:49 UTC
Regession in:
changeset 523d0868b28b in cnd-main ((none))
details: http://hg.netbeans.org/cnd-main/rev/523d0868b28b
description:
	fixing #221235 - removed/added folder appears twice in project view
	(after #215568 - Cannot put unmanaged project in VCS)
	- before adding new folder search if it is already present
Comment 2 Alexander Simon 2012-11-02 08:39:56 UTC
*** Bug 221313 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Simon 2012-11-02 08:42:46 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/ab59419c37fe
Comment 4 soldatov 2012-11-02 09:15:17 UTC
regression in previous beta2-stopper
Comment 5 soldatov 2012-11-02 10:42:48 UTC
IDE tests are restarted on latest build:
first suite has 1 failure only (expected failure)
Comment 6 soldatov 2012-11-02 11:04:29 UTC
second test suite has expected failures only too.

I will mark this bug as 'VERIFIED'.
Comment 7 Egor Ushakov 2012-11-02 12:35:21 UTC
integrated into release73_beta2:
http://hg.netbeans.org/releases/rev/a8d73f0cdcea
Comment 8 Quality Engineering 2012-11-02 17:23:31 UTC
Integrated into 'releases', will be available in build *201211021451* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/a8d73f0cdcea
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #221312 "Add Existing Item..." menu item doesn't work
(transplanted from ab59419c37fe1656f8ac0970b2ae95d505939157)
Comment 9 Quality Engineering 2012-11-03 02:42:14 UTC
Integrated into 'main-golden', will be available in build *201211030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ab59419c37fe
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #221312 "Add Existing Item..." menu item doesn't work
Comment 10 soldatov 2012-11-06 14:46:47 UTC
verified in NetBeans IDE 7.3 Beta 2 (Build 201211052012)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo