Bug 221256 - Paste stops working
Paste stops working
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Window System
7.3
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 13:49 UTC by tim_sa
Modified: 2012-11-05 10:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE logs (253.54 KB, application/octet-stream)
2012-11-01 13:51 UTC, tim_sa
Details
logs (149.56 KB, application/octet-stream)
2012-11-05 09:10 UTC, tim_sa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim_sa 2012-11-01 13:49:04 UTC
[ JDK VERSION : <1.7.7 ]

Copy and paste stops working.

Copy from an external editor and try and paste into NetBeans, the last data
that was copied within NetBeans is pasted into the editor and not the data that
you copied from the external editor.

I don't have the steps to reproduce - other than that I was copying and pasting
data from an external editor, but this has now happened to me with build
201210240001 and web-main-9050-on-20121031

As noted in this comment ( netbeans.org/bugzilla/show_bug.cgi?id=218447#c21 )
there is a screencast if you're interested in observing the behavior.
Comment 1 tim_sa 2012-11-01 13:51:24 UTC
Created attachment 126920 [details]
IDE logs

-J-Dorg.glassfish.tools.ide.level=0 -J-Dglassfish.level=0 are causing the FINEST statements
Comment 2 Milutin Kristofic 2012-11-01 14:53:45 UTC
Paste functionality works in my 
Product Version: NetBeans IDE Dev (Build 201210310001)
and previous
Product Version: NetBeans IDE Dev (Build 201210220001)
Comment 3 Stanislav Aubrecht 2012-11-01 15:42:26 UTC
The movie doesn't help when diagnosing the bug. Please run the IDE with -J-Dorg.netbeans.NbClipboard.level=0 switch to turn clipboard logging on, reproduce the problem and attach new IDE log file and reopen, thanks.
Comment 4 tim_sa 2012-11-05 09:09:53 UTC
I *don't* know if this is related to this issue, but I just got this exception in NetBeans

java.io.IOException: system clipboard data unavailable
	at sun.awt.windows.WClipboard.getClipboardData(Native Method)
	at sun.awt.datatransfer.ClipboardTransferable.fetchOneFlavor(ClipboardTransferable.java:118)
	at sun.awt.datatransfer.ClipboardTransferable.<init>(ClipboardTransferable.java:97)
	at sun.awt.datatransfer.SunClipboard.getContents(SunClipboard.java:147)
	at org.netbeans.NbClipboard$GetContents.run(NbClipboard.java:416)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1454)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2036)


log to follow
Comment 5 tim_sa 2012-11-05 09:10:34 UTC
Created attachment 127118 [details]
logs
Comment 6 Stanislav Aubrecht 2012-11-05 09:24:33 UTC
Thanks for the log but do you have the full IDE log? There might have been some other exception that broke the system clipboard.

Also it seems that copy/paste started working again, am I right?
Comment 7 tim_sa 2012-11-05 09:37:07 UTC
(In reply to comment #6)
> Thanks for the log but do you have the full IDE log? There might have been some
> other exception that broke the system clipboard.
> 
> Also it seems that copy/paste started working again, am I right?

I got this ( http://netbeans.org/bugzilla/attachment.cgi?id=127118 ) from  %APPDATA%\NetBeans\dev\var\log\messages.log 
Is there some other place I should get the log file from?

And yes you're correct the copy/paste worked after this exception was thrown
Comment 8 Stanislav Aubrecht 2012-11-05 10:06:02 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Thanks for the log but do you have the full IDE log? There might have been some
> > other exception that broke the system clipboard.
> > 
> > Also it seems that copy/paste started working again, am I right?
> 
> I got this ( http://netbeans.org/bugzilla/attachment.cgi?id=127118 ) from 
> %APPDATA%\NetBeans\dev\var\log\messages.log 
> Is there some other place I should get the log file from?
That's correct path but you need to quit NetBeans first to ensure all caches are written to the log.
> 
> And yes you're correct the copy/paste worked after this exception was thrown
Do you have any specific steps to reproduce?

See also this issue: http://netbeans.org/bugzilla/show_bug.cgi?id=221359
Comment 9 tim_sa 2012-11-05 10:32:03 UTC
> > I got this ( http://netbeans.org/bugzilla/attachment.cgi?id=127118 ) from 
> > %APPDATA%\NetBeans\dev\var\log\messages.log 
> > Is there some other place I should get the log file from?
> That's correct path but you need to quit NetBeans first to ensure all caches
> are written to the log.

Ok I didn't know that. I've looked at the log files (including the log.1 and log.2 files) and it looks like that particular set of exceptions has already disappeared. I'll shutdown the IDE next time to get the full logs.

> > 
> > And yes you're correct the copy/paste worked after this exception was thrown
> Do you have any specific steps to reproduce?

Unfortunately I don't have steps to reproduce. I was copying a file using the Microsoft Remote Desktop Connection Client (RDP), but was unable to reproduce the behavior when I tried again.


> See also this issue: http://netbeans.org/bugzilla/show_bug.cgi?id=221359

I'm not sure if these are related, as I didn't think that NetBeans was hanging at the time.
Comment 10 Stanislav Aubrecht 2012-11-05 10:37:18 UTC
Attach the full IDE log and then reopen, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo