Bug 221225 - LowPerformance took 6428 ms.
LowPerformance took 6428 ms.
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: JDK Problems
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 08:41 UTC by Egor Ushakov
Modified: 2013-08-01 09:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (16.46 KB, application/nps)
2012-11-01 08:41 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2012-11-01 08:41:39 UTC
Build: NetBeans IDE Dev (Build 20121101-0675dff5ae9a)
VM: Java HotSpot(TM) Client VM, 20.12-b01, Java(TM) SE Runtime Environment, 1.6.0_37-b06
OS: SunOS

User Comments:
gorrus: added nfs share to favorites

rptmaestro: Right-clicked in favorites to open file chooser for adding a folder.

gorrus: adding nfs folder to favorites



Maximum slowness yet reported was 7347 ms, average is 5219
Comment 1 Egor Ushakov 2012-11-01 08:41:42 UTC
Created attachment 126905 [details]
nps snapshot
Comment 2 Ondrej Vrabec 2012-11-01 08:54:43 UTC
seems to be a problem of a slow Java file chooser:
javax.swing.JComponent.processKeyEvent(): 3820 / 0
javax.swing.JComponent.processKeyBindings(): 3820 / 0
javax.swing.JComponent.processKeyBinding(): 3820 / 0
javax.swing.SwingUtilities.notifyAction(): 3820 / 0
javax.swing.plaf.basic.BasicFileChooserUI$ApproveSelectionAction.actionPerformed(): 3820 / 0
    java.io.File.exists(): 3820 / 0
    java.io.UnixFileSystem.getBooleanAttributes(): 3820 / 0
Comment 3 Stanislav Aubrecht 2013-08-01 09:49:08 UTC
All reports are from JDK 1.6
Please reopen if reproducible with the latest update of JDK 1.7, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo