Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 221211 - GlassFish is invoking keyring on IDE start
GlassFish is invoking keyring on IDE start
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.3
PC All
: P3 (vote)
: 7.4
Assigned To: TomasKraus
issues@serverplugins
NB_ONLY
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 22:10 UTC by Petr Hejl
Modified: 2013-07-22 19:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.09 KB, text/plain)
2012-10-31 22:10 UTC, Petr Hejl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2012-10-31 22:10:00 UTC
Created attachment 126892 [details]
stacktrace

With registered GF keyring is invoked on every IDE start without any user action. This is IMO very impolite and confusing (user didn't do any action any IDE want access to his keyring).
Comment 1 TomasKraus 2012-11-02 13:29:39 UTC
Unfortunately GF keyring is required to access server administration interface.
Server status is being checked after startup, but at this moment it's at least happening outside startup itself.
You should already know about all those Keyring deadlock issues I was fighting with since I used it to store administrator's password.

I did not write this status requesting code so don't ask me why it's working this way. We both just have to accept the fact that it's there and we can try to find out how to get rid of this in the future.

I won't change this in 7.3, it's too late to rewrite those things from scratch.
Comment 2 Petr Hejl 2012-11-02 13:39:13 UTC
(In reply to comment #1)
> Unfortunately GF keyring is required to access server administration interface.
> Server status is being checked after startup, but at this moment it's at least
> happening outside startup itself.
Status check after startup is imo wrong.

> You should already know about all those Keyring deadlock issues I was fighting
> with since I used it to store administrator's password.
> 
> I did not write this status requesting code so don't ask me why it's working
> this way. We both just have to accept the fact that it's there and we can try
> to find out how to get rid of this in the future.
The issue is not about "us" it is about users and user experience.

> 
> I won't change this in 7.3, it's too late to rewrite those things from scratch.
I'm ok with that.
Comment 3 Petr Jiricka 2012-11-02 14:06:29 UTC
> Server status is being checked after startup

I'd also like to know why we do this and why we can't make it later. What do we do for the other servers?
Comment 4 Petr Hejl 2012-11-02 15:04:25 UTC
(In reply to comment #3)
> > Server status is being checked after startup
> 
> I'd also like to know why we do this and why we can't make it later. What do we
> do for the other servers?
AFAIK we do nothing. It will happen on server node expansion, before deployment, etc. Infrastructure is not invoking status check on the IDE start.
Comment 5 Petr Jiricka 2012-11-02 16:26:12 UTC
That's what I thought - so GlassFish should behave the same.
Comment 6 TomasKraus 2012-11-02 21:59:05 UTC
I'll rewrite it for next release to follow other servers behavior.
Also we may put those things as plugin requirements on some wiki for the future.
Comment 7 Petr Jiricka 2012-11-05 09:25:31 UTC
I don't understand - so has this regressed recently, or has this been broken for a long time? If it broke recently, then it should be easy to fix soon, no?
Comment 8 Petr Hejl 2012-11-05 09:41:58 UTC
(In reply to comment #7)
> I don't understand - so has this regressed recently, or has this been broken
> for a long time? If it broke recently, then it should be easy to fix soon, no?

AFAIK the code checking GF on startup has been there for a long time, but it has not been using Keyring. Now the GF plugin is using Keyring (which is good) and the dialog appears on every IDE start (not so good).
Comment 9 Petr Jiricka 2012-11-05 10:12:04 UTC
If the dialog appears on every IDE start, then is that still a P3? Sounds like a P2 to me.
Comment 10 Petr Hejl 2012-11-05 10:38:02 UTC
(In reply to comment #9)
> If the dialog appears on every IDE start, then is that still a P3? Sounds like
> a P2 to me.
Not sure. It appears on every IDE start for those who don't have a system keyring or the system keyring can't cooperate with the IDE. In other words it appears when the fallback keyring is used.
Comment 11 TomasKraus 2012-11-22 14:19:42 UTC
I added this into my plan for next release.
Comment 12 TomasKraus 2013-07-18 14:56:02 UTC
New status monitoring is pushed in but it did not change anything in this area. It just made status check responses much faster.

Currently it shall access Keyring on Servers node expansion - it needs current server status to display proper icon - which also indicates if server is running or not (running servers have small green arrow in icon).

I know that you guys may not like it but this is how it was written in the past and now I understand the reason and relation between selected icon and this server status check.

But there is at least some user action at the beginning - expanding Servers node.

If you really do want this to be changed, I can replace green arrow with question mark and do nothing until user will select refresh. But I personally do not see any big issue with current behavior.
Comment 13 TomasKraus 2013-07-22 13:32:44 UTC
Closing this bug after short discussion with Petr Hejl.

Plugin will invoke Keyring (because of background monitoring) when Servers node is expanded and there is at least one of servers active (something is listening on admin port).
Comment 14 Petr Hejl 2013-07-22 19:42:10 UTC
Tomasi, as the report is about "invoking Keyring on every IDE start without any user action" this bug is fixed not wontfix.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo