Bug 221174 - IllegalArgumentException: run.single
IllegalArgumentException: run.single
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: Inspection
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Jan Stola
issues@web
EXCEPTIONS_REPORT, 73beta2-stopper-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 12:59 UTC by muellermi
Modified: 2012-11-07 11:18 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.91 KB, text/plain)
2012-10-31 12:59 UTC, muellermi
Details
stacktrace (2.91 KB, text/plain)
2012-11-02 13:41 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2012-10-31 12:59:46 UTC
Build: NetBeans IDE Dev (Build 201210310001)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows 8

User Comments:
muellermi: run the file in the browser wit Netbeans integration...




Stacktrace: 
java.lang.IllegalArgumentException: run.single
   at org.netbeans.spi.project.support.LookupProviderSupport$MergedActionProvider.invokeAction(LookupProviderSupport.java:275)
   at org.netbeans.modules.web.inspect.ui.CssStylesPanelProviderImpl$1.actionPerformed(CssStylesPanelProviderImpl.java:132)
   at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
   at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
   at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
   at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
Comment 1 muellermi 2012-10-31 12:59:48 UTC
Created attachment 126854 [details]
stacktrace
Comment 2 Milos Kleint 2012-10-31 14:39:24 UTC
The logic in the merger (which mergers all actionproviders found in the lookup) is following:
It iterates all ActionProviders and if the action is among the supported ones and is enabled, it's invoked. If no match is found, the exception is thrown. So the error is either on the side of the caller, which doesn't check if the action is supported and/or enabled or it's on the side of one or more of the implementations that mis-implement the methods.

reassigning to the caller of the ActionProvider
Comment 3 David Konecny 2012-11-01 03:12:44 UTC
Honza, this looks like web.inspect.ui.CssStylesPanelProviderImpl$1.actionPerformed(CssStylesPanelProviderImpl.java:132) got called on Java Web Project? HTML5 projects does not have LookupProviderSupport$MergedActionProvider in its lookup.
Comment 4 David Konecny 2012-11-01 03:13:09 UTC
Possibly something we want to fix for Beta2.
Comment 5 Jan Stola 2012-11-01 15:00:27 UTC
> web.inspect.ui.CssStylesPanelProviderImpl$1.actionPerformed
> (CssStylesPanelProviderImpl.java:132) got called on Java Web Project?

First of all, it is unfortunate that this view is shown for HTML file from Java or Web project. I have filled a separate issue about that - issue 221263. I also updated the view such that it is more robust. It checks for the presence of run.single action and disables the corresponding button when the action is not present. Hence, it is disabled for HTML files in Java and Web projects.

Modified files: http://hg.netbeans.org/web-main/rev/5fab6a20f7cb
Comment 6 Marek Fukala 2012-11-01 15:31:56 UTC
Please note I've just fixed issue #221263 so Honza can simply decide if the panel should be visible for a file or not.

http://hg.netbeans.org/web-main/rev/686842c36716
Comment 7 Jiri Skrivanek 2012-11-02 13:41:06 UTC
Created attachment 127014 [details]
stacktrace

To reproduce:
- create web project with JavaServer Faces and GlassFish server
- create new JSF page
- there is stylesheet view next to editor
- click "Run response.xhtml" and exception appears
Comment 8 Jiri Skrivanek 2012-11-02 18:37:47 UTC
Please, fix it for beta2. Css styles view should not be visible for html or xhtml files from java or web projects.
Comment 9 Jan Stola 2012-11-02 19:14:50 UTC
(In reply to comment #8)
> Please, fix it for beta2. Css styles view should not be visible for html or
> xhtml files from java or web projects.

It is a bit unfortunate to request this in this issue. Note that this issue is about the IllegalArgumentException only. There is another issue (221263) that is about hiding of Selection section of CSS Styles view in Java/Web projects, but event that issue is not about hiding of the whole CSS Styles view. If you really want that then it would be much better to fill a separate issue.
Comment 10 Jiri Skrivanek 2012-11-05 09:18:15 UTC
Filed separate bug 221463 as suggested.
Comment 11 Petr Jiricka 2012-11-05 14:38:55 UTC
> Css styles view should not be visible for html or xhtml files 
> from java or web projects.

I agree this is a separate discussion (and let's discuss in bug 221463 that Jirka filed), but that part is not a beta stopper. On  the other hand, the IllegalArgumentException, plus the fact that selection tab should be hidden if not applicable, ARE beta stoppers. Honzo, we just discussed with Jirka S, can you please transplant any applicable changesets to beta2? 

BTW, I see that in trunk the Selection tab is no longer visible when not applicable - can you please post what is the changeset for that?
Comment 12 Tomas Danek 2012-11-05 15:56:38 UTC
Can you please integrate fix for beta2 ASAP so that we could produce beta2 build?
Comment 13 Jan Stola 2012-11-05 16:15:13 UTC
I have integrated all related change-sets into release73_beta2 branch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo