Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 221151 - AbstractMethodError: org.netbeans.modules.bugtracking.kenai.spi.KenaiAccessor.addPropertyChangeListener(Ljava/beans/PropertyChangeListener;)V
AbstractMethodError: org.netbeans.modules.bugtracking.kenai.spi.KenaiAccessor...
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
:
: 221203 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 08:38 UTC by markiewb
Modified: 2012-11-02 15:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.30 KB, text/plain)
2012-10-31 08:38 UTC, markiewb
Details
stacktrace (5.73 KB, text/plain)
2012-11-02 15:17 UTC, michbarsinai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2012-10-31 08:38:44 UTC
Build: NetBeans IDE Dev (Build 201210310001)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.12-b01, Java(TM) SE Runtime Environment, 1.6.0_37-b06
OS: Windows 7

User Comments:
jdlee: I get this error at application start.

markiewb: Starting a NetBeans Dev Build

alesak: when ide starts




Stacktrace: 
java.lang.AbstractMethodError: org.netbeans.modules.bugtracking.kenai.spi.KenaiAccessor.addPropertyChangeListener(Ljava/beans/PropertyChangeListener;)V
   at org.netbeans.modules.bugtracking.kenai.KenaiRepositories.addPropertyChangeListener(KenaiRepositories.java:118)
   at org.netbeans.modules.bugtracking.api.RepositoryManager.<init>(RepositoryManager.java:84)
   at org.netbeans.modules.bugtracking.api.RepositoryManager.getInstance(RepositoryManager.java:93)
   at org.netbeans.modules.tasks.ui.DashboardTopComponent.componentOpened(DashboardTopComponent.java:210)
   at org.openide.windows.WindowManager.componentOpenNotify(WindowManager.java:307)
   at org.netbeans.core.windows.WindowManagerImpl.notifyTopComponentOpened(WindowManagerImpl.java:1140)
Comment 1 markiewb 2012-10-31 08:38:46 UTC
Created attachment 126828 [details]
stacktrace
Comment 2 Ondrej Vrabec 2012-10-31 08:52:21 UTC
spec version not increased in core-main #7ab3e20b91be when the SPI change was made
Comment 3 Ondrej Vrabec 2012-10-31 08:54:14 UTC
fix: http://hg.netbeans.org/core-main/rev/cf3a67e90c30
Comment 4 Tomas Stupka 2012-10-31 19:01:53 UTC
*** Bug 221203 has been marked as a duplicate of this bug. ***
Comment 5 Quality Engineering 2012-11-01 02:44:05 UTC
Integrated into 'main-golden', will be available in build *201211010001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cf3a67e90c30
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #221151 - AbstractMethodError: org.netbeans.modules.bugtracking.kenai.spi.KenaiAccessor.addPropertyChangeListener(Ljava/beans/PropertyChangeListener;)V
increasing the spec version to force the current version of the module showing in updates
Comment 6 michbarsinai 2012-11-02 15:17:07 UTC
Created attachment 127025 [details]
stacktrace

Selected the git>commit item from the project contextual menu.
The error report dialog appeared behind the git commit dialog.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo