Bug 221126 - NullPointerException at org.netbeans.api.project.ProjectUtils$BasicInformation.getDisplayName
NullPointerException at org.netbeans.api.project.ProjectUtils$BasicInformatio...
Status: RESOLVED FIXED
Product: javame
Classification: Unclassified
Component: Build System
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Tomas Zezula
issues@mobility
EXCEPTIONS_REPORT
:
: 221433 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 18:32 UTC by lehel
Modified: 2012-11-05 07:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.54 KB, text/plain)
2012-10-30 18:32 UTC, lehel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2012-10-30 18:32:44 UTC
Build: NetBeans IDE Dev (Build 201210240001)
VM: Java HotSpot(TM) Client VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows XP

User Comments:
lehel: Opening a J2ME project written in Netbeans 7.2

GUEST: ???????? ???? ? ?????????? ? ???? ????? ?? ????? ?
????? ?????? ??????

???? ??? ???????? ?? ????
http://netbeans.org/kb/docs/javame/splashscreen_ru.html?print=yes

GUEST: Creating project

zinckingeye: Opening sample j2me project from c:\

GUEST: Starting a new Mobile Application

GUEST: I was opening J2ME project.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.api.project.ProjectUtils$BasicInformation.getDisplayName(ProjectUtils.java:244)
   at org.netbeans.api.project.ProjectUtils$AnnotateIconProxyProjectInformation.getDisplayName(ProjectUtils.java:348)
   at org.netbeans.modules.project.ui.problems.BrokenReferencesImpl.showCustomizer(BrokenReferencesImpl.java:183)
   at org.netbeans.api.project.ui.ProjectProblems.showCustomizer(ProjectProblems.java:108)
   at org.netbeans.spi.java.project.support.ui.BrokenReferencesSupport.showAlert(BrokenReferencesSupport.java:167)
   at org.netbeans.modules.mobility.project.J2MEProject$ProjectOpenedHookImpl$2.run(J2MEProject.java:766)
Comment 1 lehel 2012-10-30 18:32:46 UTC
Created attachment 126799 [details]
stacktrace
Comment 2 Milos Kleint 2012-10-31 06:16:25 UTC
it appears that j2meproject can sometimes return null from getProjectDirectory() which is wrong. reassigning
Comment 3 Tomas Zezula 2012-10-31 08:30:07 UTC
Not so wrong when the project does not exist anymore (eg. deleted).
IMHO the J2ME project just return AntProjectHelper.getProjectDirectory().
In fact the project is not a J2ME project it's some other project, I think it's a lazy project.
Comment 4 Tomas Zezula 2012-10-31 09:57:55 UTC
Fixed jet-main 2e8a06485e06
Comment 5 Quality Engineering 2012-11-01 02:41:24 UTC
Integrated into 'main-golden', will be available in build *201211010001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2e8a06485e06
User: Tomas Zezula <tzezula@netbeans.org>
Log: #221126:NullPointerException at org.netbeans.api.project.ProjectUtils$BasicInformation.getDisplayName
Comment 6 Milos Kleint 2012-11-05 07:58:01 UTC
*** Bug 221433 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo