Bug 221092 - [73cat] coding problem on generated files (web service clientl)
[73cat] coding problem on generated files (web service clientl)
Status: RESOLVED DUPLICATE of bug 216526
Product: webservices
Classification: Unclassified
Component: JAX-WS
6.x
PC Windows 8
: P1 (vote)
: TBD
Assigned To: Denis Anisimov
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 14:19 UTC by muellermi
Modified: 2013-11-30 12:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2012-10-30 14:19:40 UTC
Product Version = NetBeans IDE Dev (Build 201210300001)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_09
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.5-b02

Using Win7 German version, the genrator for classes from a web service client inserts a comment like " * <p>Java-Klasse für updateAccount complex type."
My translation:
 * <p>Java class for updateAccount complex type.

This file is generated using the ANSI character set. The Java compiler tries to read and compile this as UTF-8 file. Thus, the German umlaut cannot be read:

D:\projects\WebRequest\build\generated-sources\jax-ws\org\inek\requestservice\services\UpdateAccount.java:10: error: unmappable character for encoding UTF-8
 * <p>Java-Klasse f?r updateAccount complex type.

As a result, the whole build fails.
Comment 1 muellermi 2012-10-30 14:32:38 UTC
I'm trying to generate the files using xjc manually. I'll report if I'm able to discover new information.
Comment 2 muellermi 2012-10-30 14:39:14 UTC
Generating the classes via xjc ("c:\Program Files\Java\jdk1.7.0_09\bin\xjc.exe" .) by myself creates classes with English comments

 * <p>Java class for account complex type.

May NB use a different (e.g. bundled) xjc?
Comment 3 Denis Anisimov 2012-10-30 14:46:52 UTC
It's the same issue as #216526 .
xjc is used in both cases. xjc classpath is taken from target JEE server.

*** This bug has been marked as a duplicate of bug 216526 ***
Comment 4 rawnuksingh 2013-11-30 12:50:21 UTC
int x,y,z;
x=Double.parseDouble(a.getText);
y=Double.parseDouble(b.getText);
z=Double.parseDouble(c.getText);
// TODO add your handling code here:

i was not able to remove gettext error 
what should i do ?
i am making a program which was given in my school book.
jtextfield1=a
jtextfield2=b
jtextfield3=c
when i was getting a,b,c it was giving eroor what shoid i do?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo