Bug 221044 - Profiler TopComponents cannot be fully resized
Profiler TopComponents cannot be fully resized
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.0
All All
: P4 (vote)
: 7.3
Assigned To: Jiri Sedlacek
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 17:35 UTC by Jiri Sedlacek
Modified: 2012-11-01 02:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Sedlacek 2012-10-29 17:35:42 UTC
TopComponents created by profiler have non-zero minimum size which prevents the views to be fully minimized.

To reproduce the problem, open a heap dump and drag the IDE main window to decrease its width. At some point the width of HeapWalker stays unchanged according to minimum width of its toolbar.

The problem is more visible in VisualVM where the view is at some point resized back to its preferred size and a scroll bar is added.
Comment 1 Jiri Sedlacek 2012-10-29 17:39:55 UTC
Fixed by http://hg.netbeans.org/profiler-main/rev/88a0567789aa.
Comment 2 Quality Engineering 2012-11-01 02:42:01 UTC
Integrated into 'main-golden', will be available in build *201211010001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/88a0567789aa
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #221044 - profiler top components should have zero minimum size


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo