Bug 220769 - NullPointerException at org.netbeans.lib.profiler.heap.HprofProxy.getProperties
NullPointerException at org.netbeans.lib.profiler.heap.HprofProxy.getProperties
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Tomas Hurka
issues@profiler
EXCEPTIONS_REPORT
: VISUALVM
: 220770 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 14:12 UTC by Exceptions Reporter
Modified: 2013-07-04 07:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (690 bytes, text/plain)
2012-10-24 14:12 UTC, Exceptions Reporter
Details
Heap dump to reproduce the issue (4.76 MB, application/zip)
2012-10-24 18:56 UTC, Tomas Hurka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-10-24 14:12:54 UTC
This issue was reported manually by thurka.
It already has 1 duplicates 


Build: NetBeans IDE 7.2.1 (Build 201210100934)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.12-b01-434, Java(TM) SE Runtime Environment, 1.6.0_37-b06-434-10M3909
OS: Mac OS X

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.lib.profiler.heap.HprofProxy.getProperties(HprofProxy.java:65)
   at org.netbeans.lib.profiler.heap.HprofHeap.getSystemProperties(HprofHeap.java:291)
   at org.netbeans.modules.profiler.heapwalk.OverviewController.getSystemProperties(OverviewController.java:370)
   at org.netbeans.modules.profiler.heapwalk.OverviewController.computeEnvironment(OverviewController.java:225)
   at org.netbeans.modules.profiler.heapwalk.ui.OverviewControllerUI$1.run(OverviewControllerUI.java:144)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
Comment 1 Exceptions Reporter 2012-10-24 14:12:56 UTC
Created attachment 126480 [details]
stacktrace
Comment 2 Tomas Hurka 2012-10-24 14:55:40 UTC
*** Bug 220770 has been marked as a duplicate of this bug. ***
Comment 3 Tomas Hurka 2012-10-24 18:56:16 UTC
Created attachment 126499 [details]
Heap dump to reproduce the issue
Comment 4 Tomas Hurka 2012-10-24 19:16:23 UTC
Fixed in profiler-main

changeset:   236797:fce7e8c7ec3e
user:        Tomas Hurka <thurka@netbeans.org>
date:        Wed Oct 24 21:10:22 2012 +0200
summary:     bugfix #220769, 'table' instance field can be null when the heap dump is partially broken

changeset:   236798:92b04f730863
user:        Tomas Hurka <thurka@netbeans.org>
date:        Wed Oct 24 21:14:34 2012 +0200
summary:     bugfix #220769, correctly handle case when getSystemProperties() returns null
Comment 5 Quality Engineering 2012-10-25 10:53:28 UTC
Integrated into 'main-golden', will be available in build *201210250921* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/fce7e8c7ec3e
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #220769, 'table' instance field can be null when the heap dump is partially broken


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo