Bug 220697 - AssertionError: OperationSupport cannot be null because OperationContainer contains elements: [] and invalid elements []
AssertionError: OperationSupport cannot be null because OperationContainer co...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.3
All All
: P3 (vote)
: 8.0
Assigned To: Jiri Rechtacek
au-issues
EXCEPTIONS_REPORT
:
: 220698 221429 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 23:51 UTC by Chiana
Modified: 2013-11-15 03:04 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (10.92 KB, text/plain)
2013-08-06 09:47 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chiana 2012-10-23 23:51:53 UTC
This bug was originally marked as duplicate of bug 158350, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201210231040)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Linux

User Comments:
Chiana: Created a new java application, running on Ubuntu in a virtual environment.




Stacktrace: 
java.lang.AssertionError: OperationSupport cannot be null because OperationContainer contains elements: [] and invalid elements []
   at org.netbeans.modules.autoupdate.ui.wizards.UninstallStep.handleAction(UninstallStep.java:169)
   at org.netbeans.modules.autoupdate.ui.wizards.UninstallStep.doAction(UninstallStep.java:155)
   at org.netbeans.modules.autoupdate.ui.wizards.UninstallStep.access$000(UninstallStep.java:70)
   at org.netbeans.modules.autoupdate.ui.wizards.UninstallStep$1.propertyChange(UninstallStep.java:129)
   at java.beans.PropertyChangeSupport.fire(PropertyChangeSupport.java:335)
   at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:327)
Comment 1 Jiri Rechtacek 2012-10-24 08:23:27 UTC
*** Bug 220698 has been marked as a duplicate of this bug. ***
Comment 2 Jiri Rechtacek 2012-11-18 20:12:38 UTC
*** Bug 221429 has been marked as a duplicate of this bug. ***
Comment 3 Egor Ushakov 2013-08-06 09:47:12 UTC
Created attachment 138342 [details]
stacktrace

installed a plugin
Comment 4 Jiri Rechtacek 2013-11-12 11:47:57 UTC
http://hg.netbeans.org/core-main/rev/f181eb3935e9
Comment 5 Quality Engineering 2013-11-15 03:04:20 UTC
Integrated into 'main-silver', will be available in build *201311150002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/f181eb3935e9
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #220697 - AssertionError: OperationSupport cannot be null because OperationContainer contains elements: [] and invalid elements []


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo