Bug 220631 - Creation of webstart.war broken since 1.6.0_32, missing jnlp-servlet.jar
Creation of webstart.war broken since 1.6.0_32, missing jnlp-servlet.jar
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
7.3
PC Linux
: P2 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 08:41 UTC by Jaroslav Tulach
Modified: 2013-01-21 16:05 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2012-10-23 08:41:10 UTC
Caught by failing tests:

org.netbeans.modules.apisupport.project.BuildFeedreaderTest.testBuildJNLP 	org.netbeans.modules.apisupport.project.BuildPaintapplicationTest.testBuildJNLP 

This is the build error message:

INFO: suite-jnlp.build:
Oct 22, 2012 10:33:34 AM org.netbeans.modules.apisupport.project.InputOutputProviderImpl$OW write
INFO: println: /hudson/workdir/jobs/ergonomics/workspace/nbbuild/netbeans/harness/suite.xml:520: The following error occurred while executing this line: listener: Hyperlink[file:/hudson/workdir/jobs/ergonomics/workspace/nbbuild/netbeans/harness/suite.xml:520:-1:-1:-1]
Oct 22, 2012 10:33:34 AM org.netbeans.modules.apisupport.project.InputOutputProviderImpl$OW write
INFO: select
Oct 22, 2012 10:33:34 AM org.netbeans.modules.apisupport.project.InputOutputProviderImpl$OW write
INFO: println: /hudson/workdir/jobs/ergonomics/workspace/nbbuild/netbeans/harness/jnlp.xml:209: Point -Djnlp.servlet.jar to your jnlp-servlet.jar, usually in $JDKHOME/sample/jnlp/servlet/jnlp-servlet.jar listener: Hyperlink[file:/hudson/workdir/jobs/ergonomics/workspace/nbbuild/netbeans/harness/jnlp.xml:209:-1:-1:-1]
Oct 22, 2012 10:33:34 AM org.netbeans.modules.apisupport.project.InputOutputProviderImpl$OW write
INFO: BUILD FAILED (total time: 9 seconds)
Comment 1 Jaroslav Tulach 2012-10-23 10:39:39 UTC
Quote from:
http://docs.oracle.com/javase/6/docs/technotes/guides/jweb/applet/codebase_determination.html

In the new Java Plug-in introduced in the Java SE 6 update 10 release, a codebase is always provided by the browser, either because it was explicitly specified, or implicitly obtained from the location of the HTML document. This allows relative URLs to be used in JNLP files, which is very useful for moving an entire tree of content from one server to another.

We should probably change the jnlp file generator to require JDK6_u10 and always use relative paths. We don't need presence of any servlet then.
Comment 2 Quality Engineering 2012-10-25 10:51:48 UTC
Integrated into 'main-golden', will be available in build *201210250921* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6a2db5783d84
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #220631: Temporarily marking the JNLP related tests as randomly failing. Need to investigate how to get the right functionality back on JDK 1.6.0_37 and newer
Comment 3 Jaroslav Tulach 2012-10-30 10:25:02 UTC
The $JDK_HOME/sample/jnlp/servlet/jnlp-servlet.jar is missing in new JDKs as they come without the sample code by default. I'd like to include copy of the jnlp-servlet.jar under the harness cluster. The files in the JAR have following license:

/*
 * %W% %E%
 * 
 * Copyright (c) 2006, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions are met:
 *
 * -Redistribution of source code must retain the above copyright notice, this
 *  list of conditions and the following disclaimer.
 *
 * -Redistribution in binary form must reproduce the above copyright notice,
 *  this list of conditions and the following disclaimer in the documentation
 *  and/or other materials provided with the distribution.
 *
 * Neither the name of Oracle or the names of contributors may
 * be used to endorse or promote products derived from this software without
 * specific prior written permission.
 *
 * This software is provided "AS IS," without a warranty of any kind. ALL
 * EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING
 * ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE
 * OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. ("SUN")
 * AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE
 * AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS
 * DERIVATIVES. IN NO EVENT WILL SUN OR ITS LICENSORS BE LIABLE FOR ANY LOST
 * REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL,
 * INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY
 * OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SOFTWARE,
 * EVEN IF SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
 *
 * You acknowledge that this software is not designed, licensed or intended
 * for use in the design, construction, operation or maintenance of any
 * nuclear facility.
 */

Please confirm, it is OK to include the JAR.
Comment 4 Antonin Nebuzelsky 2012-10-30 16:50:58 UTC
Note: 6u32 was the first JDK 6u release where samples and demos need to be downloaded separately.
Comment 5 Antonin Nebuzelsky 2012-12-14 15:45:47 UTC
Have a confirmation from Ashwin to include the jnlp-servlet.jar file.

Jardo, please proceed with the fix.
Comment 6 Jaroslav Tulach 2012-12-17 12:59:56 UTC
ergonomics#5ff650cd8cb6
Comment 7 Quality Engineering 2012-12-20 02:45:20 UTC
Integrated into 'main-golden', will be available in build *201212200001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5ff650cd8cb6
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #220631: Providing own copy of jnlp-servlet.jar
Comment 8 Tomas Danek 2013-01-21 16:05:39 UTC
JNLP can be built fine in

Product Version: NetBeans IDE 7.3 RC1 (Build 201301202100)
Java: 1.7.0_11; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
System: Mac OS X version 10.8.2 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.3rc1
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.3rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo