Bug 220514 - [73cat] "Throwable: Locked by:" during reformatting code for all project (C++ CMake based project)
[73cat] "Throwable: Locked by:" during reformatting code for all project (C++...
Status: CLOSED DUPLICATE of bug 220474
Product: platform
Classification: Unclassified
Component: Text
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 17:05 UTC by kosmonaffft
Modified: 2013-09-02 10:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.14 KB, text/plain)
2012-10-21 17:05 UTC, kosmonaffft
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kosmonaffft 2012-10-21 17:05:52 UTC
Build: NetBeans IDE Dev (Build 201210200002)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b10
OS: Windows 8

User Comments:
kosmonaFFFt: Reformat all project...




Stacktrace: 
java.lang.Throwable: Locked by:
   at org.openide.filesystems.FileLock.<init>(FileLock.java:85)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.<init>(LockForFile.java:91)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.tryLock(LockForFile.java:102)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.lock(FileObj.java:359)
   at org.openide.loaders.MultiDataObject$Entry.takeLock(MultiDataObject.java:1356)
   at org.netbeans.modules.cnd.source.CppEditorSupport$Environment.takeLock(CppEditorSupport.java:394)
Comment 1 kosmonaffft 2012-10-21 17:05:53 UTC
Created attachment 126268 [details]
stacktrace
Comment 2 Alexander Simon 2012-10-22 13:12:17 UTC
It seems this bug is result of fixing bug #220381

CloneableEditorSupport.saveDocument()
in lines:
            setLastSaveTime(-1);
            os = cesEnv().outputStream();
            memoryOutputStream[0].writeTo(os);
            os.close(); // performs firing
does not release file lock.
Comment 3 Alexander Simon 2012-10-22 13:17:31 UTC
Probably bug #220474 is a duplicate of this bug.
Comment 4 Miloslav Metelka 2013-08-28 12:59:14 UTC
So marked as dup of issue 220474

*** This bug has been marked as a duplicate of bug 220474 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo