Bug 220254 - gdb embedded remote debugging fails
gdb embedded remote debugging fails
Status: RESOLVED DUPLICATE of bug 170488
Product: cnd
Classification: Unclassified
Component: Debugger
7.2
All All
: P3 (vote)
: TBD
Assigned To: henk89
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 08:58 UTC by Egor Ushakov
Modified: 2012-10-25 15:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
gdblog (23.78 KB, text/plain)
2012-10-17 08:59 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2012-10-17 08:58:49 UTC
From users@cnd (matthias@blaicher.com):

I' currently trying to get openocd and netbeans to work. Netbeans starts and runs my program. I can also break on existing breakpoints. But pausing and step out/over etc. do not work.

I think this has something to do with how netbeans parses the gdb answers. I see a lot of stuff like:

Code:

14-exec-run
=thread-exited,id="1",group-id="i1"
=thread-group-exited,id="i1"
=thread-group-started,id="i1",pid="42000"
=thread-created,id="1",group-id="i1"
~"Note: automatically using hardware breakpoints for read-only addresses.\n"
14^running
*running,thread-id="all"
(gdb) 
No answer for: 14-exec-run



Clearly, gdb responded correctly to the -exec-run command. Netbeans just fails to understand it.
Comment 1 Egor Ushakov 2012-10-17 08:59:33 UTC
Created attachment 126059 [details]
gdblog
Comment 2 Egor Ushakov 2012-10-25 15:39:31 UTC
as pause still does not work for such targets, see bug 170488, any actions does not work while gdb is running

*** This bug has been marked as a duplicate of bug 170488 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo