Bug 219864 - NullPointerException at javax.swing.CellRendererPane.addImpl
NullPointerException at javax.swing.CellRendererPane.addImpl
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: JDK Problems
7.3
All All
: P2 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT
:
: 215609 222321 224899 231869 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 02:05 UTC by Milutin Kristofic
Modified: 2013-07-01 15:57 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.16 KB, text/plain)
2012-10-11 02:06 UTC, Milutin Kristofic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milutin Kristofic 2012-10-11 02:05:57 UTC
Build: NetBeans IDE Dev (Build 201210080002)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.8-b03, Java(TM) SE Runtime Environment, 1.6.0_33-b04
OS: Linux

Stacktrace: 
java.lang.NullPointerException
   at javax.swing.CellRendererPane.addImpl(CellRendererPane.java:85)
   at java.awt.Container.add(Container.java:363)
   at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1345)
   at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1294)
   at javax.swing.plaf.basic.BasicListUI.getPreferredSize(BasicListUI.java:561)
   at javax.swing.JComponent.getPreferredSize(JComponent.java:1634)
Comment 1 Milutin Kristofic 2012-10-11 02:06:02 UTC
Created attachment 125729 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2012-11-06 15:48:49 UTC
This doesn't seem to be a JDK issue. List render simply returns a null component for some reason...
Please provide steps to reproduce and reopen, thanks.
Comment 3 Marian Mirilovic 2012-11-18 19:07:41 UTC
*** Bug 222321 has been marked as a duplicate of this bug. ***
Comment 4 Marian Mirilovic 2013-01-15 16:22:16 UTC
*** Bug 224899 has been marked as a duplicate of this bug. ***
Comment 5 Marian Mirilovic 2013-01-15 16:22:31 UTC
We have new report ...
Comment 6 Marian Mirilovic 2013-06-27 11:44:54 UTC
number of dups is rising ...
Comment 7 Marian Mirilovic 2013-06-27 11:45:12 UTC
*** Bug 231869 has been marked as a duplicate of this bug. ***
Comment 8 Marian Mirilovic 2013-06-27 11:50:13 UTC
*** Bug 215609 has been marked as a duplicate of this bug. ***
Comment 9 Stanislav Aubrecht 2013-06-27 12:41:41 UTC
I found two instances of null ListCellRenderer - one in Quicksearch dropdown list and one in bugtracking. Fixed in core-main 24de261a3b5c

But there might be other bad renderer implementations so please reopen if still reproducible (and provide steps to reproduce).
Comment 10 Quality Engineering 2013-07-01 15:57:53 UTC
Integrated into 'main-silver', will be available in build *201307011244* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/24de261a3b5c
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #219864 - NPE when rendering a JList


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo