Bug 219682 - CodeCompletion took 8486 ms.
CodeCompletion took 8486 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Editor
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 07:47 UTC by medeag
Modified: 2012-10-19 09:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (88.32 KB, application/nps)
2012-10-08 07:48 UTC, medeag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medeag 2012-10-08 07:47:55 UTC
This bug was originally marked as duplicate of bug 214760, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201210070002)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.1-b03, Java(TM) SE Runtime Environment, 1.7.0_05-b06
OS: Windows 7

User Comments:
medeag: code completion



Maximum slowness yet reported was 8486 ms, average is 8486
Comment 1 medeag 2012-10-08 07:48:00 UTC
Created attachment 125561 [details]
nps snapshot
Comment 2 Dusan Balek 2012-10-19 09:21:02 UTC
Code completion is waiting for ClassIndex.getElements(...) which seems to be slow due to slow IO at the moment. Nothing to fix on the code completion side. 'Please wait' should be displayed meanwhile. Closing as WONTFIX.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo