Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 21951 - Do not load classes on startup
Do not load classes on startup
Status: CLOSED FIXED
Product: xml
Classification: Unclassified
Component: Code
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: _ lkramolis
issues@xml
: PERFORMANCE
Depends on:
Blocks: 21676
  Show dependency treegraph
 
Reported: 2002-03-28 16:37 UTC by Jaroslav Tulach
Modified: 2005-03-09 04:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
CVS commit report - changelog. (18.69 KB, text/plain)
2002-04-05 15:59 UTC, _ lkramolis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2002-03-28 16:37:36 UTC
I am working on issue 21676 and I have run the IDE with this patch
http://www.netbeans.org/issues/showattachment.cgi?attach_id=5081 and the
arguments described there. I have found out that following classes are being
loaded into the system on startup. Please investigate why they are loaded and
prevent that to happen. Thanks.

org.netbeans.modules.xml.core.tree.ModuleEntityResolver
org.netbeans.modules.xml.catalog.CatalogEntityResolver
org.netbeans.modules.xml.catalog.spi.CatalogProvider
org.netbeans.modules.xml.catalog.impl.SystemCatalogProvider
org.netbeans.modules.xml.catalog.impl.XCatalogProvider
org.netbeans.modules.xml.catalog.impl.sun.SunCatalogProvider
org.netbeans.modules.xml.core.actions.CollectDTDAction$DTDAction
org.netbeans.modules.xml.tools.actions.CSSStyleAction
org.netbeans.modules.xml.core.actions.CollectXMLAction$XMLAction
org.netbeans.modules.xml.tools.actions.CheckAction
org.netbeans.modules.xml.tools.actions.CheckDTDAction
org.netbeans.modules.xml.tools.actions.ValidateAction
org.netbeans.modules.xml.tools.doclet.DocletAction
org.netbeans.modules.xml.core.cookies.CookieFactoryCreator
org.netbeans.modules.xml.core.DTDDataObject$DTDCookieFactoryCreator
org.netbeans.modules.xml.tools.generator.DTDGenerateSupportFactory$Creator
org.netbeans.modules.xml.tools.generator.XMLGenerateAction
org.netbeans.modules.xml.tools.generator.XMLGenerateAction$GenerateDOMScannerAction
org.netbeans.modules.xml.tools.generator.XMLGenerateAction$GenerateDTDAction
org.netbeans.modules.xml.tools.generator.XMLGenerateAction$GenerateDocumentHandlerAction
org.netbeans.modules.xml.core.XMLDataObject$XMLCookieFactoryCreator
org.netbeans.modules.xml.tools.generator.XMLGenerateSupportFactory$Creator
org.netbeans.modules.xml.tools.transform.actions.TransformAction
org.netbeans.modules.xml.core.text.TextEditorSupport$EditorSupportFactoryCreater
org.netbeans.modules.xml.tree.editor.TreeEditorSupport$TreeEditorSupportFactoryCreator
org.netbeans.modules.xml.core.DTDDataObject$DataNodeCreator
org.netbeans.modules.xml.tree.nodes.DTDDataNode$DataNodeCreatorImpl
org.netbeans.modules.xml.core.XMLDataObject$DataNodeCreator
org.netbeans.modules.xml.tree.nodes.XMLDataNode$DataNodeCreatorImpl
org.netbeans.modules.xml.core.XMLDefaultLook
org.netbeans.modules.xml.tree.nodes.looks.XMLStructureLook
Comment 1 _ lkramolis 2002-04-04 07:20:19 UTC
I already fixed simple cases - Manifest layer: .instance files
replaced by .settings files.
Comment 2 _ lkramolis 2002-04-05 15:59:56 UTC
Created attachment 5312 [details]
CVS commit report - changelog.
Comment 3 _ lkramolis 2002-04-05 16:11:28 UTC
After discussion with Jarda I did not used .settings files which need
to be parsed. I have just extended .instance files with instanceClass,
instanceCreate and instanceOf attributes.

Attached commit-log fixes loading of most of mentioned classes.
Following 7 classes are loaded from XMLDataObject and are used to
complete its CookieSet -- still loaded:

org.netbeans.modules.xml.core.cookies.CookieFactoryCreator
org.netbeans.modules.xml.core.XMLDataObject$XMLCookieFactoryCreator
org.netbeans.modules.xml.tools.generator.XMLGenerateSupportFactory$Creator
org.netbeans.modules.xml.core.text.TextEditorSupport$EditorSupportFactoryCreater
org.netbeans.modules.xml.tree.editor.TreeEditorSupport$TreeEditorSupportFactoryCreator
org.netbeans.modules.xml.core.XMLDefaultLook
org.netbeans.modules.xml.tree.nodes.looks.XMLStructureLook
Comment 4 _ lkramolis 2002-04-10 16:38:16 UTC
Rolled-back usage of instanceOf attributes -- lookup does not find
such declared instances, this could be openide problem.

Jardo, don't you know anything about it? Thanks.
Comment 5 Jaroslav Tulach 2002-04-13 14:06:18 UTC
Added tests and it seems that they work. The problem is likely to be
on your side...

/cvs/openide/test/unit/src/org/openide/loaders/InstanceDataObjectTest.java,v 
<--  InstanceDataObjectTest.java
new revision: 1.20; previous revision: 1.19

Comment 6 Martin Schovanek 2002-04-22 09:54:02 UTC
Due Honza Ch. bug statistics version changed on 3.4 dev.
Comment 7 _ lkramolis 2002-05-28 10:11:26 UTC
Just necessary classes are loaded now.

Mainly changes were made in mf-layer.xml ducuments using instanceOf
attributes.
Comment 8 Martin Schovanek 2002-07-24 13:18:51 UTC
VERIFIED
Comment 9 Quality Engineering 2003-07-02 08:39:01 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo