Bug 219371 - Ctlr+Shift+D to select the next item in clipboard history
Ctlr+Shift+D to select the next item in clipboard history
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Milutin Kristofic
issues@editor
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 11:49 UTC by Vladimir Voskresensky
Modified: 2016-07-14 01:51 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
implementation (2.33 KB, patch)
2012-12-17 14:25 UTC, Milutin Kristofic
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2012-10-02 11:49:51 UTC
when Ctrl+Shitf+D popup is visible it would be great if pressing next Ctrl+Shift+D moves selection to the next line (now I have to press ArrowDown for that which needs to relocation of fingers on keyboard)
Comment 1 Svata Dedic 2012-12-06 14:38:49 UTC

*** This bug has been marked as a duplicate of bug 219368 ***
Comment 2 Vladimir Voskresensky 2012-12-06 14:57:35 UTC
why do you consider this ENH to be duplicates? 

I intentionally filed them as separate issues. This one describes behavior of "visible" clipboard history popup.

Another one is about "invisible" clipboard history without any popups at all.

Or do you have solution which is general enough to satisfy both?

Thanks,
Vladimir.
Comment 3 Svata Dedic 2012-12-11 12:49:01 UTC
Oops, sorry; I missed the subtle difference, thanks for explanation.
Comment 4 Milutin Kristofic 2012-12-11 12:54:13 UTC
You can press number. But good idea.
Comment 5 Milutin Kristofic 2012-12-17 14:25:02 UTC
Created attachment 129459 [details]
implementation

I implement your enhancement. I will push it to next release.
Comment 6 Martin Balin 2016-07-07 07:30:23 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss
Comment 7 Vladimir Voskresensky 2016-07-11 10:39:52 UTC
Still actual
Comment 8 Milutin Kristofic 2016-07-13 10:01:54 UTC
Thank you for reminding. Pushed to repository http://hg.netbeans.org/jet-main/rev/4e88c7668c09
Comment 9 Quality Engineering 2016-07-14 01:51:58 UTC
Integrated into 'main-silver', will be available in build *201607140002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/4e88c7668c09
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #219371 - Ctlr+Shift+D to select the next item in clipboard history


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo