Bug 219155 - OutOfMemoryError after start NetBeans
OutOfMemoryError after start NetBeans
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
7.3
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 06:22 UTC by stefan79
Modified: 2013-01-21 12:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Log-File. (122.28 KB, text/plain)
2012-09-28 06:22 UTC, stefan79
Details
Message at Upload. (60.18 KB, image/png)
2012-10-01 12:53 UTC, stefan79
Details
Log-File. (56.00 KB, application/octet-stream)
2012-10-04 09:42 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2012-09-28 06:22:04 UTC
Created attachment 125047 [details]
Log-File.

Yesterday, I restarted NetBeans and after 20 minutes scanning, an OutOfMemoryError occured.
(Xmx is set to 2G!)
Comment 1 stefan79 2012-09-28 07:35:11 UTC
The Dump is available at (Zipfile with 2 parts):
https://skydrive.live.com/redir?resid=FF30805754BC2B3E!203&authkey=!AJVGXnTHlZ34Kr4
Comment 2 Marian Mirilovic 2012-09-29 08:07:12 UTC
reassign to performance team for evaluation
Comment 3 Petr Cyhelsky 2012-10-01 09:06:01 UTC
can you please upload the heapdump to:
http://deadlock.netbeans.org/hudson/job/upload/build

the skydrive requires some microsoft account...
Comment 4 stefan79 2012-10-01 12:53:28 UTC
Created attachment 125151 [details]
Message at Upload.

(In reply to comment #3)
> can you please upload the heapdump to:
> http://deadlock.netbeans.org/hudson/job/upload/build
Upload doesn´t works (I´ve tried it two times, but I only got the Error-Message.
 
> the skydrive requires some microsoft account...
No! There´s public access at this folder.
Comment 5 Petr Cyhelsky 2012-10-02 07:45:16 UTC
Can you please try again - it seems the hudson node was temporarily offline, can you please try again.

> No! There´s public access at this folder.

if that is so, than for skydrive public="anyone with Microsoft account" which is not the regular definition of public.
Comment 6 stefan79 2012-10-03 08:13:42 UTC
(In reply to comment #5)
> Can you please try again - it seems the hudson node was temporarily offline,
> can you please try again.
I think upload worked now (there was no error; but I haven´t seen any info that the upload was successfull).
 
> > No! There´s public access at this folder.
> 
> if that is so, than for skydrive public="anyone with Microsoft account" which
> is not the regular definition of public.
Sorry. I thougth this is really public (but here´s only the view public but not the download).
Comment 7 Tomas Hurka 2012-10-04 07:37:46 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Can you please try again - it seems the hudson node was temporarily offline,
> > can you please try again.
> I think upload worked now (there was no error; but I haven´t seen any info that
> the upload was successfull).
Thanks. Upload was successful. One more note - please use zip instead of rar next time.
Comment 8 stefan79 2012-10-04 09:42:21 UTC
Created attachment 125368 [details]
Log-File.

Yesterday the same at 201210030002:
-) I refreshed my source -> Background Scanning startet
-) about 30 Minutes, the IDE-Response was very slow
   -> So I killed the process
-) Than I started NetBeans 
   -> OutOfMemoryError occured
   Closed NB
-) Than I started NetBeans again
   -> OutOfMemoryError occured
   Closed NB
-) Than I started NetBeans again
   Indexing finished and everything works fine.

Should I upload the Dumps?
Comment 9 Tomas Hurka 2012-10-23 10:11:52 UTC
The problem is caused by enormous source root. OnePassCompileWorker needs a lot of memory to compile it. Unfortunately javac code does not check for low memory when it does compilation.
Comment 10 Dusan Balek 2012-10-23 12:49:36 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/32b156255cdb
Comment 11 Quality Engineering 2012-10-24 01:28:37 UTC
Integrated into 'main-golden', will be available in build *201210240001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/32b156255cdb
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #219155: OutOfMemoryError after start NetBeans - fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo