Bug 219154 - Classcast exception while renaming package
Classcast exception while renaming package
Status: RESOLVED DUPLICATE of bug 218766
Product: java
Classification: Unclassified
Component: Refactoring
7.3
PC Windows 7 x64
: P3 (vote)
: 7.3
Assigned To: Ralph Ruijs
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-28 05:53 UTC by akobberup
Modified: 2012-10-01 06:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description akobberup 2012-09-28 05:53:05 UTC
Got this exception while renaming a package containing .java files and .txt files..

java.lang.ClassCastException: org.netbeans.modules.refactoring.api.RenameRefactoring cannot be cast to org.netbeans.modules.refactoring.api.MoveRefactoring
	at org.netbeans.modules.refactoring.java.plugins.MoveFileRefactoringPlugin.getRelevantFiles(MoveFileRefactoringPlugin.java:476)
	at org.netbeans.modules.refactoring.java.plugins.MoveFileRefactoringPlugin.prepare(MoveFileRefactoringPlugin.java:553)
[catch] at org.netbeans.modules.refactoring.api.AbstractRefactoring.pluginsPrepare2(AbstractRefactoring.java:437)
	at org.netbeans.modules.refactoring.api.AbstractRefactoring.pluginsPrepare(AbstractRefactoring.java:421)
	at org.netbeans.modules.refactoring.api.AbstractRefactoring.prepare(AbstractRefactoring.java:232)
	at org.netbeans.modules.refactoring.spi.impl.ParametersPanel$Prepare.run(ParametersPanel.java:1013)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1454)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2036)
Comment 1 Ralph Ruijs 2012-10-01 06:43:51 UTC

*** This bug has been marked as a duplicate of bug 218766 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo