Bug 219131 - Creating Master/Detail Form Hangs During Creation
Creating Master/Detail Form Hangs During Creation
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Progress
7.3
PC Windows 7
: P1 (vote)
: 7.3
Assigned To: Antonin Nebuzelsky
issues@platform
73beta-stopper-fixed
: REGRESSION
: 219128 (view as bug list)
Depends on: 215281
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 17:58 UTC by MackSix
Modified: 2012-10-01 12:02 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log and Thread Dump (120.84 KB, text/plain)
2012-09-27 17:59 UTC, MackSix
Details
Thread Dump Only (34.49 KB, text/plain)
2012-09-27 18:00 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2012-09-27 17:58:56 UTC
1. Create new Java project
2. Invoke New File wizard
3. Choose 'Swing GUI Forms - Master/Detail Sample Form' and press 'Next >'
4. Change name to e.g. "MyMasterDetail" and press 'Next >'
5. Choose sample database connection and leave 'CUSTOMER' as Database Table. Press 'Next >'
6. In section "Create Detail Area as": check "Table" option
7. Press "Finish" button 

Netbeans hangs at this point.

See attached logfile and thread dump.

Product Version: NetBeans IDE 7.3 Beta (Build 201209232010)
Java: 1.7.0_07; Java HotSpot(TM) 64-Bit Server VM 23.3-b01
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)


No workaround that I know of and this is regression. -> P1
Comment 1 MackSix 2012-09-27 17:59:36 UTC
Created attachment 125026 [details]
Log and Thread Dump
Comment 2 MackSix 2012-09-27 18:00:02 UTC
Created attachment 125027 [details]
Thread Dump Only
Comment 3 MackSix 2012-09-27 19:36:57 UTC
*** Bug 219128 has been marked as a duplicate of this bug. ***
Comment 4 Marian Mirilovic 2012-09-29 09:44:20 UTC
100% reproducible in NB 7.3 Beta on Ubuntu 12.04 / JDK 7u10 b09 64b
Comment 5 David Strupl 2012-09-29 14:47:42 UTC
Evaluating ...
Comment 6 David Strupl 2012-09-29 15:00:20 UTC
Reproducible on Win 7, JDK 7u7.
Comment 7 David Strupl 2012-09-29 15:28:20 UTC
If I read the thread dump correctly the problem is in:

org.netbeans.modules.progress.ui.AbstractWindowRunner.start(AbstractWindowRunner.java:179)

in AWT EDT. I am not sure what it is supposed to do but opening dialog and from that another dialog 

at org.netbeans.modules.progress.ui.AbstractWindowRunner$3.run(AbstractWindowRunner.java:333)

might cause the trouble. I am trying to assign to the owner of that component to have look.
Comment 8 David Strupl 2012-09-29 16:07:00 UTC
I think this is a typo in private JDialog createModalProgressDialog(...) on lines 329-...:

        if (EventQueue.isDispatchThread()) {
            EventQueue.invokeLater(new Runnable() {
                @Override
                public void run() {
                    result.setVisible(true);
                }
            });
        } else {
            result.setVisible(true);
        }

IMHO it should read 
if (!EventQueue.isDispatchThread()) ....

but I have no idea what Tim wanted to achieve by the whole changeset.
Comment 9 David Strupl 2012-09-29 16:30:05 UTC
Hmm, didn't help. Leaving the problem to the experts ...
Comment 11 Quality Engineering 2012-10-01 04:20:23 UTC
Integrated into 'releases', will be available in build *201210010205* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/5a5cbcb6f5f3
User: Antonin Nebuzelsky <anebuzelsky@netbeans.org>
Log: #219131: Creating Master/Detail Form Hangs During Creation
Comment 12 Quality Engineering 2012-10-01 12:02:11 UTC
Integrated into 'main-golden', will be available in build *201210010929* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/89f21acb1087
User: Antonin Nebuzelsky <anebuzelsky@netbeans.org>
Log: #219131: Creating Master/Detail Form Hangs During Creation


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo