Bug 219038 - 5297 ms - OpenAction.open() to websvc.rest.nodes.OpenCookieFactory$OpenCookieImpl.open()
5297 ms - OpenAction.open() to websvc.rest.nodes.OpenCookieFactory$OpenCookie...
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: REST
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Denis Anisimov
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 07:50 UTC by aquaglia
Modified: 2012-12-07 02:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (65.77 KB, application/nps)
2012-09-26 07:50 UTC, aquaglia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aquaglia 2012-09-26 07:50:47 UTC
This bug was originally marked as duplicate of bug 187919, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta (Build 201209232010)
VM: Java HotSpot(TM) Client VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows XP
Maximum slowness yet reported was 5297 ms, average is 5297
Comment 1 aquaglia 2012-09-26 07:50:54 UTC
Created attachment 124925 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2012-10-30 09:41:09 UTC
I guess that calling into parsing API is not necessary 
org.netbeans.modules.websvc.rest.support.SourceGroupSupport.getFileObjectFromClassName()	53.90249	2 781 ms (53,9%)	2 781 ms
Comment 3 Denis Anisimov 2012-12-04 06:32:57 UTC
web-main#63feb51b98ae
Comment 4 Quality Engineering 2012-12-07 02:37:11 UTC
Integrated into 'main-golden', will be available in build *201212070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/63feb51b98ae
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#219038 - 5297 ms - OpenAction.open() to websvc.rest.nodes.OpenCookieFactory$OpenCookieImpl.open()


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo